log for at.bitfire.icsdroid:53

== Installed Android Tools ==

2021-07-20 20:13:44,261 DEBUG: Reading 'config.yml'
2021-07-20 20:13:44,270 INFO: Using /opt/android-sdk/build-tools/29.0.3/apksigner 
2021-07-20 20:13:44,272 INFO: Creating log directory
2021-07-20 20:13:44,272 INFO: Creating temporary directory
2021-07-20 20:13:44,272 INFO: Creating output directory
2021-07-20 20:13:44,280 DEBUG: Getting git vcs interface for https://gitlab.com/bitfireAT/icsx5.git
2021-07-20 20:13:44,280 DEBUG: > git --version
git version 2.11.0
2021-07-20 20:13:44,497 INFO: Using git version 2.11.0
2021-07-20 20:13:44,498 DEBUG: Checking 1.9.3-beta1
2021-07-20 20:13:44,498 INFO: Building version 1.9.3-beta1 (53) of at.bitfire.icsdroid
2021-07-20 20:13:44,499 DEBUG: > sudo passwd --lock root
passwd: password expiry information changed.
2021-07-20 20:13:44,712 DEBUG: > sudo SUDO_FORCE_REMOVE=yes dpkg --purge sudo
(Reading database ... 64892 files and directories currently installed.)
Removing sudo (1.8.19p1-2.1+deb9u3) ...
Purging configuration files for sudo (1.8.19p1-2.1+deb9u3) ...
Processing triggers for systemd (232-25+deb9u12) ...
2021-07-20 20:13:49,991 INFO: Getting source for revision 931835c4369e510cd0f830a7a1edf5396a18cad7
2021-07-20 20:13:49,991 DEBUG: Directory: build/at.bitfire.icsdroid
2021-07-20 20:13:49,991 DEBUG: > git rev-parse --show-toplevel
2021-07-20 20:13:50,195 DEBUG: Directory: build/at.bitfire.icsdroid
2021-07-20 20:13:50,196 DEBUG: > git submodule foreach --recursive git reset --hard
2021-07-20 20:13:50,501 DEBUG: Directory: build/at.bitfire.icsdroid
2021-07-20 20:13:50,501 DEBUG: > git reset --hard
2021-07-20 20:13:50,706 DEBUG: Directory: build/at.bitfire.icsdroid
2021-07-20 20:13:50,706 DEBUG: > git submodule foreach --recursive git clean -dffx
2021-07-20 20:13:50,912 DEBUG: Directory: build/at.bitfire.icsdroid
2021-07-20 20:13:50,912 DEBUG: > git clean -dffx
2021-07-20 20:13:51,022 DEBUG: Directory: build/at.bitfire.icsdroid
2021-07-20 20:13:51,022 DEBUG: > git -c core.askpass=/bin/true -c core.sshCommand=/bin/false -c url.https://.insteadOf=ssh:// -c url.https://u:p@bitbucket.org/.insteadOf=git@bitbucket.org: -c url.https://u:p@bitbucket.org.insteadOf=git://bitbucket.org -c url.https://u:p@bitbucket.org.insteadOf=https://bitbucket.org -c url.https://u:p@github.com/.insteadOf=git@github.com: -c url.https://u:p@github.com.insteadOf=git://github.com -c url.https://u:p@github.com.insteadOf=https://github.com -c url.https://u:p@gitlab.com/.insteadOf=git@gitlab.com: -c url.https://u:p@gitlab.com.insteadOf=git://gitlab.com -c url.https://u:p@gitlab.com.insteadOf=https://gitlab.com fetch origin
2021-07-20 20:13:51,446 DEBUG: Directory: build/at.bitfire.icsdroid
2021-07-20 20:13:51,446 DEBUG: > git -c core.askpass=/bin/true -c core.sshCommand=/bin/false -c url.https://.insteadOf=ssh:// -c url.https://u:p@bitbucket.org/.insteadOf=git@bitbucket.org: -c url.https://u:p@bitbucket.org.insteadOf=git://bitbucket.org -c url.https://u:p@bitbucket.org.insteadOf=https://bitbucket.org -c url.https://u:p@github.com/.insteadOf=git@github.com: -c url.https://u:p@github.com.insteadOf=git://github.com -c url.https://u:p@github.com.insteadOf=https://github.com -c url.https://u:p@gitlab.com/.insteadOf=git@gitlab.com: -c url.https://u:p@gitlab.com.insteadOf=git://gitlab.com -c url.https://u:p@gitlab.com.insteadOf=https://gitlab.com fetch --prune --tags --force origin
2021-07-20 20:13:51,884 DEBUG: Directory: build/at.bitfire.icsdroid
2021-07-20 20:13:51,885 DEBUG: > git remote set-head origin --auto
2021-07-20 20:13:52,393 DEBUG: Directory: build/at.bitfire.icsdroid
2021-07-20 20:13:52,393 DEBUG: > git checkout -f 931835c4369e510cd0f830a7a1edf5396a18cad7
2021-07-20 20:13:52,613 DEBUG: Directory: build/at.bitfire.icsdroid
2021-07-20 20:13:52,613 DEBUG: > git clean -dffx
2021-07-20 20:13:52,723 INFO: Initialising submodules
2021-07-20 20:13:52,724 DEBUG: Directory: build/at.bitfire.icsdroid
2021-07-20 20:13:52,724 DEBUG: > git rev-parse --show-toplevel
2021-07-20 20:13:52,945 DEBUG: Directory: build/at.bitfire.icsdroid
2021-07-20 20:13:52,945 DEBUG: > git submodule sync
2021-07-20 20:13:53,156 DEBUG: Directory: build/at.bitfire.icsdroid
2021-07-20 20:13:53,156 DEBUG: > git -c core.askpass=/bin/true -c core.sshCommand=/bin/false -c url.https://.insteadOf=ssh:// -c url.https://u:p@bitbucket.org/.insteadOf=git@bitbucket.org: -c url.https://u:p@bitbucket.org.insteadOf=git://bitbucket.org -c url.https://u:p@bitbucket.org.insteadOf=https://bitbucket.org -c url.https://u:p@github.com/.insteadOf=git@github.com: -c url.https://u:p@github.com.insteadOf=git://github.com -c url.https://u:p@github.com.insteadOf=https://github.com -c url.https://u:p@gitlab.com/.insteadOf=git@gitlab.com: -c url.https://u:p@gitlab.com.insteadOf=git://gitlab.com -c url.https://u:p@gitlab.com.insteadOf=https://gitlab.com submodule update --init --force --recursive
Submodule path 'cert4android': checked out '87b76b388849e854c8412bed3eeb260f9b1c92e6'
Submodule path 'ical4android': checked out '39cd98ca269e4fc46f57f0f35272a0ef92abdbbf'
2021-07-20 20:13:53,474 INFO: Creating local.properties file at build/at.bitfire.icsdroid/local.properties
2021-07-20 20:13:53,475 INFO: Creating local.properties file at build/at.bitfire.icsdroid/app/local.properties
2021-07-20 20:13:53,475 DEBUG: Removing debuggable flags from build/at.bitfire.icsdroid/app
2021-07-20 20:13:53,498 INFO: Cleaning Gradle project...
2021-07-20 20:13:53,498 DEBUG: Directory: build/at.bitfire.icsdroid/app
2021-07-20 20:13:53,498 DEBUG: > /home/vagrant/fdroidserver/gradlew-fdroid clean
Found 6.7.1 via distributionUrl
Downloading missing gradle version 6.7.1
cachedir /home/vagrant/.cache/fdroidserver
/home/vagrant/.cache/fdroidserver/gradle-6.7.1-bin.zip: OK
Running /opt/gradle/versions/6.7.1/bin/gradle clean

Welcome to Gradle 6.7.1!

Here are the highlights of this release:
 - File system watching is ready for production use
 - Declare the version of Java your build requires
 - Java 15 support

For more details see https://docs.gradle.org/6.7.1/release-notes.html

To honour the JVM settings for this build a new JVM will be forked. Please consider using the daemon: https://docs.gradle.org/6.7.1/userguide/gradle_daemon.html.
Daemon will be stopped at the end of the build stopping after processing
> Task :app:clean UP-TO-DATE

Deprecated Gradle features were used in this build, making it incompatible with Gradle 7.0.
Use '--warning-mode all' to show the individual deprecation warnings.
See https://docs.gradle.org/6.7.1/userguide/command_line_interface.html#sec:command_line_warnings

BUILD SUCCESSFUL in 54s
1 actionable task: 1 up-to-date
2021-07-20 20:14:51,537 INFO: Scanning source for common problems...
2021-07-20 20:14:51,544 INFO: Removing gradle-wrapper.jar at ical4android/gradle/wrapper/gradle-wrapper.jar
2021-07-20 20:14:51,549 INFO: Removing gradle-wrapper.jar at gradle/wrapper/gradle-wrapper.jar
2021-07-20 20:14:51,558 INFO: Removing gradle-wrapper.jar at cert4android/gradle/wrapper/gradle-wrapper.jar
2021-07-20 20:14:51,563 INFO: Creating source tarball...
2021-07-20 20:14:51,724 INFO: Building Gradle project...
2021-07-20 20:14:51,724 DEBUG: Directory: build/at.bitfire.icsdroid/app
2021-07-20 20:14:51,724 DEBUG: > /home/vagrant/fdroidserver/gradlew-fdroid assembleStandardRelease
Found 6.7.1 via distributionUrl
Running /opt/gradle/versions/6.7.1/bin/gradle assembleStandardRelease
To honour the JVM settings for this build a new JVM will be forked. Please consider using the daemon: https://docs.gradle.org/6.7.1/userguide/gradle_daemon.html.
Daemon will be stopped at the end of the build stopping after processing
File /home/vagrant/.android/repositories.cfg could not be loaded.
Checking the license for package Android SDK Build-Tools 30.0.3 in /opt/android-sdk/licenses
License for package Android SDK Build-Tools 30.0.3 accepted.
Preparing "Install Android SDK Build-Tools 30.0.3 (revision: 30.0.3)".
"Install Android SDK Build-Tools 30.0.3 (revision: 30.0.3)" ready.
Installing Android SDK Build-Tools 30.0.3 in /opt/android-sdk/build-tools/30.0.3
"Install Android SDK Build-Tools 30.0.3 (revision: 30.0.3)" complete.
"Install Android SDK Build-Tools 30.0.3 (revision: 30.0.3)" finished.
Checking the license for package Android SDK Platform 30 in /opt/android-sdk/licenses
License for package Android SDK Platform 30 accepted.
Preparing "Install Android SDK Platform 30 (revision: 3)".
"Install Android SDK Platform 30 (revision: 3)" ready.
Installing Android SDK Platform 30 in /opt/android-sdk/platforms/android-30
"Install Android SDK Platform 30 (revision: 3)" complete.
"Install Android SDK Platform 30 (revision: 3)" finished.
> Task :app:preBuild UP-TO-DATE
> Task :cert4android:preBuild UP-TO-DATE
> Task :ical4android:preBuild UP-TO-DATE
> Task :ical4android:preReleaseBuild UP-TO-DATE
> Task :cert4android:preReleaseBuild UP-TO-DATE
> Task :ical4android:compileReleaseAidl NO-SOURCE
> Task :ical4android:packageReleaseRenderscript NO-SOURCE
> Task :app:extractProguardFiles
> Task :ical4android:compileReleaseRenderscript NO-SOURCE
> Task :ical4android:generateReleaseResValues
> Task :ical4android:generateReleaseResources
> Task :ical4android:packageReleaseResources
> Task :ical4android:extractDeepLinksRelease
> Task :ical4android:writeReleaseAarMetadata
> Task :ical4android:compileReleaseLibraryResources
> Task :ical4android:processReleaseManifest

> Task :app:prepareLibraryDefinitionsStandardRelease
All dependencies.size=92
--> Retrieved POM for: org_slf4j__slf4j_api from org.slf4j:slf4j-parent:1.7.30
----> Had to fallback to parent author for: org_slf4j__slf4j_api -- result: Ceki Gulcu
----> Had to fallback to parent authorWebsite for: org_slf4j__slf4j_api -- result: http://www.qos.ch
----> Had to fallback to parent version for: org_slf4j__slf4j_api -- result: 1.7.30
----> Found license from parent for: org_slf4j__slf4j_api -- result: MIT
--> Retrieved POM for: org_brotli__dec from org.brotli:parent:0.1.2
----> Had to fallback to parent authorWebsite for: org_brotli__dec -- result: https://github.com/google
----> Had to fallback to parent description for: org_brotli__dec
----> Found license from parent for: org_brotli__dec -- result: MIT
--> Retrieved POM for: com_sun_mail__android_activation from com.sun.mail:android:1.6.5
----> Had to fallback to parent description for: com_sun_mail__android_activation
----> Had to fallback to parent version for: com_sun_mail__android_activation -- result: 1.6.5
--> Retrieved POM for: commons_codec__commons_codec from org.apache.commons:commons-parent:42
--> Retrieved POM for: org_apache_commons__commons_collections4 from org.apache.commons:commons-parent:47
Could not get the name for androidx_databinding__viewbinding, Using androidx.databinding:viewbinding
--> Retrieved POM for: org_slf4j__slf4j_jdk14 from org.slf4j:slf4j-parent:1.7.30
----> Had to fallback to parent author for: org_slf4j__slf4j_jdk14 -- result: Ceki Gulcu
----> Had to fallback to parent authorWebsite for: org_slf4j__slf4j_jdk14 -- result: http://www.qos.ch
----> Had to fallback to parent version for: org_slf4j__slf4j_jdk14 -- result: 1.7.30
----> Found license from parent for: org_slf4j__slf4j_jdk14 -- result: MIT
--> Retrieved POM for: com_google_guava__listenablefuture from com.google.guava:guava-parent:26.0-android
----> Had to fallback to parent author for: com_google_guava__listenablefuture -- result: Kevin Bourrillion
----> Had to fallback to parent authorWebsite for: com_google_guava__listenablefuture -- result: http://www.google.com
----> Found license from parent for: com_google_guava__listenablefuture -- result: Apache_2_0
--> Retrieved POM for: commons_io__commons_io from org.apache.commons:commons-parent:42
--> Had to resolve name from custom mapping for: androidx_savedstate__savedstate as SavedState
--> Had to resolve author from custom mapping for: com_squareup_okio__okio as Square, Inc
--> Retrieved POM for: org_apache_commons__commons_lang3 from org.apache.commons:commons-parent:47
--> Retrieved POM for: com_sun_mail__android_mail from com.sun.mail:android:1.6.5
----> Had to fallback to parent description for: com_sun_mail__android_mail
----> Had to fallback to parent version for: com_sun_mail__android_mail -- result: 1.6.5
Could not get the name for androidx_databinding__databinding_adapters, Using androidx.databinding:databinding-adapters
Could not get the name for androidx_databinding__databinding_runtime, Using androidx.databinding:databinding-runtime

> Task :app:preStandardReleaseBuild
> Task :app:generateStandardReleaseResValues
> Task :app:dataBindingTriggerStandardRelease
> Task :ical4android:generateReleaseBuildConfig
> Task :app:generateStandardReleaseBuildConfig
> Task :app:createStandardReleaseCompatibleScreenManifests
> Task :ical4android:javaPreCompileRelease
> Task :app:extractDeepLinksStandardRelease
> Task :ical4android:prepareLintJarForPublish
> Task :app:writeStandardReleaseApplicationId
> Task :app:analyticsRecordingStandardRelease
> Task :app:mergeStandardReleaseJniLibFolders
> Task :ical4android:processReleaseJavaRes
> Task :ical4android:mergeReleaseJniLibFolders
> Task :ical4android:mergeReleaseNativeLibs NO-SOURCE
> Task :ical4android:stripReleaseDebugSymbols NO-SOURCE
> Task :ical4android:copyReleaseJniLibsProjectOnly
> Task :ical4android:parseReleaseLocalResources
> Task :app:mergeStandardReleaseShaders
> Task :app:compileStandardReleaseShaders NO-SOURCE
> Task :app:generateStandardReleaseAssets UP-TO-DATE
> Task :cert4android:compileReleaseAidl
> Task :cert4android:packageReleaseRenderscript NO-SOURCE
> Task :cert4android:compileReleaseRenderscript NO-SOURCE
> Task :cert4android:dataBindingMergeDependencyArtifactsRelease
> Task :app:compileStandardReleaseAidl NO-SOURCE
> Task :cert4android:generateReleaseResValues
> Task :cert4android:dataBindingMergeGenClassesRelease
> Task :app:compileStandardReleaseRenderscript NO-SOURCE
> Task :app:generateStandardReleaseResources
> Task :cert4android:generateReleaseResources
> Task :app:processStandardReleaseJavaRes
> Task :app:checkStandardReleaseDuplicateClasses
> Task :app:collectStandardReleaseDependencies
> Task :ical4android:mergeReleaseShaders
> Task :ical4android:compileReleaseShaders NO-SOURCE
> Task :ical4android:generateReleaseAssets UP-TO-DATE
> Task :ical4android:generateReleaseRFile
> Task :ical4android:packageReleaseAssets
> Task :app:sdkStandardReleaseDependencyData
> Task :app:writeStandardReleaseAppMetadata
> Task :app:writeStandardReleaseSigningConfigVersions
> Task :cert4android:packageReleaseResources
> Task :cert4android:dataBindingGenBaseClassesRelease
> Task :cert4android:dataBindingTriggerRelease
> Task :cert4android:generateReleaseBuildConfig
> Task :cert4android:processReleaseManifest
> Task :cert4android:parseReleaseLocalResources
> Task :cert4android:javaPreCompileRelease
> Task :cert4android:extractDeepLinksRelease
> Task :cert4android:writeReleaseAarMetadata
> Task :cert4android:prepareLintJarForPublish
> Task :cert4android:processReleaseJavaRes NO-SOURCE
> Task :cert4android:mergeReleaseJniLibFolders
> Task :cert4android:mergeReleaseNativeLibs NO-SOURCE
> Task :cert4android:stripReleaseDebugSymbols NO-SOURCE
> Task :cert4android:copyReleaseJniLibsProjectOnly
> Task :cert4android:mergeReleaseShaders
> Task :cert4android:compileReleaseShaders NO-SOURCE
> Task :cert4android:generateReleaseAssets UP-TO-DATE
> Task :cert4android:packageReleaseAssets
> Task :cert4android:generateReleaseRFile
> Task :cert4android:compileReleaseLibraryResources
> Task :app:dataBindingMergeGenClassesStandardRelease
> Task :app:checkStandardReleaseAarMetadata
> Task :app:mergeStandardReleaseResources
> Task :app:processStandardReleaseMainManifest
> Task :app:processStandardReleaseManifest
> Task :app:mergeStandardReleaseAssets
> Task :app:processStandardReleaseManifestForPackage
> Task :app:compressStandardReleaseAssets
> Task :app:processStandardReleaseResources
> Task :app:optimizeStandardReleaseResources

> Task :cert4android:compileReleaseKotlin
w: Runtime JAR files in the classpath have the version 1.4, which is older than the API version 1.5. Consider using the runtime of version 1.5, or pass '-api-version 1.4' explicitly to restrict the available APIs to the runtime of version 1.4. You can also pass '-language-version 1.4' instead, which will restrict not only the APIs to the specified version, but also the language features
w: /home/vagrant/.gradle/caches/modules-2/files-2.1/org.jetbrains.kotlin/kotlin-stdlib-common/1.4.32/ef50bfa2c0491a11dcc35d9822edbfd6170e1ea2/kotlin-stdlib-common-1.4.32.jar: Runtime JAR file has version 1.4 which is older than required for API version 1.5
w: /home/vagrant/.gradle/caches/modules-2/files-2.1/org.jetbrains.kotlin/kotlin-stdlib-jdk7/1.4.32/3546900a3ebff0c43f31190baf87a9220e37b7ea/kotlin-stdlib-jdk7-1.4.32.jar: Runtime JAR file has version 1.4 which is older than required for API version 1.5
w: /home/vagrant/.gradle/caches/modules-2/files-2.1/org.jetbrains.kotlin/kotlin-stdlib/1.4.32/461367948840adbb0839c51d91ed74ef4a9ccb52/kotlin-stdlib-1.4.32.jar: Runtime JAR file has version 1.4 which is older than required for API version 1.5
w: /home/vagrant/build/at.bitfire.icsdroid/cert4android/src/main/java/at/bitfire/cert4android/TrustCertificateActivity.kt: (54, 27): Parameter 'view' is never used
w: /home/vagrant/build/at.bitfire.icsdroid/cert4android/src/main/java/at/bitfire/cert4android/TrustCertificateActivity.kt: (59, 27): Parameter 'view' is never used

> Task :cert4android:compileReleaseJavaWithJavac
> Task :cert4android:bundleLibResRelease
> Task :cert4android:mergeReleaseGeneratedProguardFiles
> Task :app:dataBindingMergeDependencyArtifactsStandardRelease
> Task :cert4android:bundleLibCompileToJarRelease
> Task :cert4android:exportReleaseConsumerProguardFiles
> Task :cert4android:bundleLibRuntimeToJarRelease
> Task :app:dataBindingGenBaseClassesStandardRelease

> Task :ical4android:compileReleaseKotlin
w: /home/vagrant/build/at.bitfire.icsdroid/ical4android/src/main/java/at/bitfire/ical4android/AndroidEvent.kt: (897, 49): 'toUpperCase(Locale): String' is deprecated. Use uppercase() instead.
w: /home/vagrant/build/at.bitfire.icsdroid/ical4android/src/main/java/at/bitfire/ical4android/AndroidTask.kt: (369, 56): 'toUpperCase(Locale): String' is deprecated. Use uppercase() instead.
w: /home/vagrant/build/at.bitfire.icsdroid/ical4android/src/main/java/at/bitfire/ical4android/AttendeeMappings.kt: (45, 27): Variable 'role' initializer is redundant
w: /home/vagrant/build/at.bitfire.icsdroid/ical4android/src/main/java/at/bitfire/ical4android/util/TimeApiExtensions.kt: (138, 13): The value '0' assigned to 'var weeks: Long defined in at.bitfire.ical4android.util.TimeApiExtensions.toRfc5545Duration' is never used

> Task :ical4android:compileReleaseJavaWithJavac
> Task :ical4android:bundleLibResRelease
> Task :ical4android:bundleLibCompileToJarRelease
> Task :ical4android:mergeReleaseGeneratedProguardFiles
> Task :ical4android:exportReleaseConsumerProguardFiles
> Task :ical4android:bundleLibRuntimeToJarRelease
> Task :app:mergeStandardReleaseNativeLibs
> Task :app:kaptGenerateStubsStandardReleaseKotlin
> Task :app:stripStandardReleaseDebugSymbols
> Task :app:extractStandardReleaseNativeSymbolTables
> Task :app:mergeStandardReleaseNativeDebugMetadata NO-SOURCE
> Task :app:kaptStandardReleaseKotlin

> Task :app:compileStandardReleaseKotlin
w: /home/vagrant/build/at.bitfire.icsdroid/app/src/main/java/at/bitfire/icsdroid/ui/AddCalendarEnterUrlFragment.kt: (89, 13): Variable 'view' is never used
w: /home/vagrant/build/at.bitfire.icsdroid/app/src/main/java/at/bitfire/icsdroid/ui/AddCalendarEnterUrlFragment.kt: (114, 31): 'toLowerCase(Locale): String' is deprecated. Use lowercase() instead.
w: /home/vagrant/build/at.bitfire.icsdroid/app/src/main/java/at/bitfire/icsdroid/ui/AddCalendarEnterUrlFragment.kt: (122, 29): 'requestPermissions(Array<(out) String!>, Int): Unit' is deprecated. Deprecated in Java
w: /home/vagrant/build/at.bitfire.icsdroid/app/src/main/java/at/bitfire/icsdroid/ui/AddCalendarValidationFragment.kt: (13, 20): 'ProgressDialog' is deprecated. Deprecated in Java
w: /home/vagrant/build/at.bitfire.icsdroid/app/src/main/java/at/bitfire/icsdroid/ui/AddCalendarValidationFragment.kt: (51, 61): 'getColor(Int): Int' is deprecated. Deprecated in Java
w: /home/vagrant/build/at.bitfire.icsdroid/app/src/main/java/at/bitfire/icsdroid/ui/AddCalendarValidationFragment.kt: (75, 24): 'constructor ProgressDialog(Context!)' is deprecated. Deprecated in Java
w: /home/vagrant/build/at.bitfire.icsdroid/app/src/main/java/at/bitfire/icsdroid/ui/AddCalendarValidationFragment.kt: (75, 24): 'ProgressDialog' is deprecated. Deprecated in Java
w: /home/vagrant/build/at.bitfire.icsdroid/app/src/main/java/at/bitfire/icsdroid/ui/AddCalendarValidationFragment.kt: (76, 18): 'setMessage(CharSequence!): Unit' is deprecated. Deprecated in Java
w: /home/vagrant/build/at.bitfire.icsdroid/app/src/main/java/at/bitfire/icsdroid/ui/AlertFragment.kt: (45, 59): 'from(Activity): ShareCompat.IntentBuilder' is deprecated. Deprecated in Java
w: /home/vagrant/build/at.bitfire.icsdroid/app/src/main/java/at/bitfire/icsdroid/ui/CalendarListActivity.kt: (67, 45): 'getColor(Int): Int' is deprecated. Deprecated in Java
w: /home/vagrant/build/at.bitfire.icsdroid/app/src/main/java/at/bitfire/icsdroid/ui/CalendarListActivity.kt: (180, 23): Parameter 'v' is never used
w: /home/vagrant/build/at.bitfire.icsdroid/app/src/main/java/at/bitfire/icsdroid/ui/CalendarListActivity.kt: (188, 20): Parameter 'item' is never used
w: /home/vagrant/build/at.bitfire.icsdroid/app/src/main/java/at/bitfire/icsdroid/ui/CalendarListActivity.kt: (192, 27): Parameter 'item' is never used
w: /home/vagrant/build/at.bitfire.icsdroid/app/src/main/java/at/bitfire/icsdroid/ui/CalendarListActivity.kt: (196, 26): Parameter 'item' is never used
w: /home/vagrant/build/at.bitfire.icsdroid/app/src/main/java/at/bitfire/icsdroid/ui/CalendarListActivity.kt: (345, 30): 'release(): Boolean' is deprecated. Deprecated in Java
w: /home/vagrant/build/at.bitfire.icsdroid/app/src/main/java/at/bitfire/icsdroid/ui/EditCalendarActivity.kt: (163, 16): Parameter 'item' is never used
w: /home/vagrant/build/at.bitfire.icsdroid/app/src/main/java/at/bitfire/icsdroid/ui/EditCalendarActivity.kt: (190, 21): Parameter 'item' is never used
w: /home/vagrant/build/at.bitfire.icsdroid/app/src/main/java/at/bitfire/icsdroid/ui/EditCalendarActivity.kt: (212, 18): Parameter 'item' is never used
w: /home/vagrant/build/at.bitfire.icsdroid/app/src/main/java/at/bitfire/icsdroid/ui/EditCalendarActivity.kt: (216, 17): Parameter 'item' is never used
w: /home/vagrant/build/at.bitfire.icsdroid/app/src/main/java/at/bitfire/icsdroid/ui/EditCalendarActivity.kt: (218, 39): 'from(Activity): ShareCompat.IntentBuilder' is deprecated. Deprecated in Java
w: /home/vagrant/build/at.bitfire.icsdroid/app/src/main/java/at/bitfire/icsdroid/ui/EditCalendarActivity.kt: (252, 26): 'release(): Boolean' is deprecated. Deprecated in Java
w: /home/vagrant/build/at.bitfire.icsdroid/app/src/main/java/at/bitfire/icsdroid/ui/InfoActivity.kt: (61, 21): Parameter 'item' is never used
w: /home/vagrant/build/at.bitfire.icsdroid/app/src/main/java/at/bitfire/icsdroid/ui/InfoActivity.kt: (65, 21): Parameter 'item' is never used
w: /home/vagrant/build/at.bitfire.icsdroid/app/src/main/java/at/bitfire/icsdroid/ui/InfoActivity.kt: (69, 27): Parameter 'uri' is never used
w: /home/vagrant/build/at.bitfire.icsdroid/app/src/main/java/at/bitfire/icsdroid/ui/TitleColorFragment.kt: (38, 13): 'startActivityForResult(Intent!, Int): Unit' is deprecated. Deprecated in Java

> Task :app:compileStandardReleaseJavaWithJavac
> Task :app:compileStandardReleaseSources

> Task :app:lintVitalStandardRelease
w: Runtime JAR files in the classpath should have the same version. These files were found in the classpath:
    /home/vagrant/.gradle/caches/modules-2/files-2.1/org.jetbrains.kotlin/kotlin-stdlib-jdk7/1.5.10/c49d0703d16c6cb1526cc07b9b46486da1dd8a60/kotlin-stdlib-jdk7-1.5.10.jar (version 1.5)
    /home/vagrant/.gradle/caches/modules-2/files-2.1/org.jetbrains.kotlin/kotlin-stdlib/1.5.10/da6a904b132f0402fa4d79169a3c1770598d4702/kotlin-stdlib-1.5.10.jar (version 1.5)
    /home/vagrant/.gradle/caches/modules-2/files-2.1/org.jetbrains.kotlin/kotlin-stdlib-common/1.5.10/6b84d926e28493be69daf673e40076f89492ef7/kotlin-stdlib-common-1.5.10.jar (version 1.5)
    /home/vagrant/.gradle/caches/modules-2/files-2.1/org.jetbrains.kotlin/kotlin-stdlib-jdk7/1.5.21/f059658740a4b3a3461aba9681457615332bae1c/kotlin-stdlib-jdk7-1.5.21.jar (version 1.5)
    /home/vagrant/.gradle/caches/modules-2/files-2.1/org.jetbrains.kotlin/kotlin-stdlib/1.4.32/461367948840adbb0839c51d91ed74ef4a9ccb52/kotlin-stdlib-1.4.32.jar (version 1.4)
    /home/vagrant/.gradle/caches/modules-2/files-2.1/org.jetbrains.kotlin/kotlin-stdlib-common/1.4.32/ef50bfa2c0491a11dcc35d9822edbfd6170e1ea2/kotlin-stdlib-common-1.4.32.jar (version 1.4)
    /home/vagrant/.gradle/caches/modules-2/files-2.1/org.jetbrains.kotlin/kotlin-stdlib-jdk7/1.4.32/3546900a3ebff0c43f31190baf87a9220e37b7ea/kotlin-stdlib-jdk7-1.4.32.jar (version 1.4)
    /home/vagrant/.gradle/caches/modules-2/files-2.1/org.jetbrains.kotlin/kotlin-stdlib-jdk8/1.4.10/998caa30623f73223194a8b657abd2baec4880ea/kotlin-stdlib-jdk8-1.4.10.jar (version 1.4)
    /home/vagrant/.gradle/caches/modules-2/files-2.1/org.jetbrains.kotlin/kotlin-stdlib-jdk8/1.5.21/6b3de2a43405a65502728047db37a98a0c7e72f0/kotlin-stdlib-jdk8-1.5.21.jar (version 1.5)
    /home/vagrant/.gradle/caches/modules-2/files-2.1/org.jetbrains.kotlin/kotlin-stdlib/1.5.21/2f537cad7e9eeb9da73738c8812e1e4cf9b62e4e/kotlin-stdlib-1.5.21.jar (version 1.5)
    /home/vagrant/.gradle/caches/modules-2/files-2.1/org.jetbrains.kotlin/kotlin-stdlib-common/1.5.21/cc8bf3586fd2ebcf234058b9440bb406e62dfacb/kotlin-stdlib-common-1.5.21.jar (version 1.5)
w: Some runtime JAR files in the classpath have an incompatible version. Consider removing them from the classpath

> Task :app:mergeStandardReleaseGeneratedProguardFiles
> Task :app:mergeStandardReleaseJavaResource
> Task :app:minifyStandardReleaseWithR8
> Task :app:l8DexDesugarLibStandardRelease
> Task :app:packageStandardRelease
> Task :app:assembleStandardRelease

Deprecated Gradle features were used in this build, making it incompatible with Gradle 7.0.
Use '--warning-mode all' to show the individual deprecation warnings.
See https://docs.gradle.org/6.7.1/userguide/command_line_interface.html#sec:command_line_warnings

BUILD SUCCESSFUL in 2m 38s
92 actionable tasks: 92 executed
2021-07-20 20:17:30,283 DEBUG: Popen(['git', 'cat-file', '--batch-check'], cwd=/home/vagrant/build/at.bitfire.icsdroid, universal_newlines=False, shell=None)
2021-07-20 20:17:30,289 INFO: Successfully built version 1.9.3-beta1 of at.bitfire.icsdroid from 931835c4369e510cd0f830a7a1edf5396a18cad7
2021-07-20 20:17:30,922 DEBUG: AXML contains a RESOURCE MAP
2021-07-20 20:17:30,923 DEBUG: Start of Namespace mapping: prefix 39: 'android' --> uri 109: 'http://schemas.android.com/apk/res/android'
2021-07-20 20:17:30,924 DEBUG: Checking build/at.bitfire.icsdroid/app/build/outputs/apk/standard/release/icsx5-53-1.9.3-beta1-standard-release-unsigned.apk
2021-07-20 20:17:30,942 DEBUG: AXML contains a RESOURCE MAP
2021-07-20 20:17:30,943 DEBUG: Start of Namespace mapping: prefix 39: 'android' --> uri 109: 'http://schemas.android.com/apk/res/android'
2021-07-20 20:17:30,972 INFO: success: at.bitfire.icsdroid
2021-07-20 20:17:30,972 INFO: Finished
2021-07-20 20:17:30,973 INFO: 1 build succeeded