log for ch.admin.bag.covidcertificate.wallet:2500

== Installed Android Tools ==

2021-09-14 15:39:42,784 DEBUG: Reading 'config.yml'
2021-09-14 15:39:42,794 INFO: Using /opt/android-sdk/build-tools/29.0.3/apksigner 
2021-09-14 15:39:42,798 INFO: Creating log directory
2021-09-14 15:39:42,798 INFO: Creating temporary directory
2021-09-14 15:39:42,798 INFO: Creating output directory
2021-09-14 15:39:42,802 DEBUG: Getting git vcs interface for https://github.com/admin-ch/CovidCertificate-App-Android
2021-09-14 15:39:42,803 DEBUG: > git --version
git version 2.11.0
2021-09-14 15:39:43,026 INFO: Using git version 2.11.0
2021-09-14 15:39:43,027 DEBUG: Checking 2.5.0
2021-09-14 15:39:43,027 INFO: Building version 2.5.0 (2500) of ch.admin.bag.covidcertificate.wallet
2021-09-14 15:39:43,028 DEBUG: > sudo passwd --lock root
passwd: password expiry information changed.
2021-09-14 15:39:43,237 DEBUG: > sudo SUDO_FORCE_REMOVE=yes dpkg --purge sudo
(Reading database ... 64894 files and directories currently installed.)
Removing sudo (1.8.19p1-2.1+deb9u3) ...
Purging configuration files for sudo (1.8.19p1-2.1+deb9u3) ...
Processing triggers for systemd (232-25+deb9u13) ...
2021-09-14 15:39:48,879 INFO: Getting source for revision 1f82fb34892c7bf8fbcc5fdc7760953635a29d3a
2021-09-14 15:39:48,880 DEBUG: Directory: build/ch.admin.bag.covidcertificate.wallet
2021-09-14 15:39:48,880 DEBUG: > git rev-parse --show-toplevel
2021-09-14 15:39:49,084 DEBUG: Directory: build/ch.admin.bag.covidcertificate.wallet
2021-09-14 15:39:49,085 DEBUG: > git submodule foreach --recursive git reset --hard
2021-09-14 15:39:49,191 DEBUG: Directory: build/ch.admin.bag.covidcertificate.wallet
2021-09-14 15:39:49,191 DEBUG: > git reset --hard
2021-09-14 15:39:49,502 DEBUG: Directory: build/ch.admin.bag.covidcertificate.wallet
2021-09-14 15:39:49,502 DEBUG: > git submodule foreach --recursive git clean -dffx
2021-09-14 15:39:49,613 DEBUG: Directory: build/ch.admin.bag.covidcertificate.wallet
2021-09-14 15:39:49,614 DEBUG: > git clean -dffx
2021-09-14 15:39:49,723 DEBUG: Directory: build/ch.admin.bag.covidcertificate.wallet
2021-09-14 15:39:49,724 DEBUG: > git -c core.askpass=/bin/true -c core.sshCommand=/bin/false -c url.https://.insteadOf=ssh:// -c url.https://u:p@bitbucket.org/.insteadOf=git@bitbucket.org: -c url.https://u:p@bitbucket.org.insteadOf=git://bitbucket.org -c url.https://u:p@bitbucket.org.insteadOf=https://bitbucket.org -c url.https://u:p@github.com/.insteadOf=git@github.com: -c url.https://u:p@github.com.insteadOf=git://github.com -c url.https://u:p@github.com.insteadOf=https://github.com -c url.https://u:p@gitlab.com/.insteadOf=git@gitlab.com: -c url.https://u:p@gitlab.com.insteadOf=git://gitlab.com -c url.https://u:p@gitlab.com.insteadOf=https://gitlab.com fetch origin
2021-09-14 15:39:50,130 DEBUG: Directory: build/ch.admin.bag.covidcertificate.wallet
2021-09-14 15:39:50,131 DEBUG: > git -c core.askpass=/bin/true -c core.sshCommand=/bin/false -c url.https://.insteadOf=ssh:// -c url.https://u:p@bitbucket.org/.insteadOf=git@bitbucket.org: -c url.https://u:p@bitbucket.org.insteadOf=git://bitbucket.org -c url.https://u:p@bitbucket.org.insteadOf=https://bitbucket.org -c url.https://u:p@github.com/.insteadOf=git@github.com: -c url.https://u:p@github.com.insteadOf=git://github.com -c url.https://u:p@github.com.insteadOf=https://github.com -c url.https://u:p@gitlab.com/.insteadOf=git@gitlab.com: -c url.https://u:p@gitlab.com.insteadOf=git://gitlab.com -c url.https://u:p@gitlab.com.insteadOf=https://gitlab.com fetch --prune --tags --force origin
2021-09-14 15:39:50,438 DEBUG: Directory: build/ch.admin.bag.covidcertificate.wallet
2021-09-14 15:39:50,438 DEBUG: > git remote set-head origin --auto
2021-09-14 15:39:50,845 DEBUG: Directory: build/ch.admin.bag.covidcertificate.wallet
2021-09-14 15:39:50,845 DEBUG: > git checkout -f 1f82fb34892c7bf8fbcc5fdc7760953635a29d3a
2021-09-14 15:39:51,155 DEBUG: Directory: build/ch.admin.bag.covidcertificate.wallet
2021-09-14 15:39:51,156 DEBUG: > git clean -dffx
2021-09-14 15:39:51,261 INFO: Creating local.properties file at build/ch.admin.bag.covidcertificate.wallet/local.properties
2021-09-14 15:39:51,262 INFO: Creating local.properties file at build/ch.admin.bag.covidcertificate.wallet/wallet/local.properties
2021-09-14 15:39:51,262 DEBUG: Removing debuggable flags from build/ch.admin.bag.covidcertificate.wallet/wallet
2021-09-14 15:39:51,269 INFO: Removing specified files
2021-09-14 15:39:51,270 INFO: Removing wallet/testKeystore
2021-09-14 15:39:51,270 INFO: Removing verifier/testKeystore
2021-09-14 15:39:51,273 INFO: Cleaned build.gradle of keysigning configs at build/ch.admin.bag.covidcertificate.wallet/wallet/build.gradle
2021-09-14 15:39:51,278 INFO: Cleaned build.gradle of keysigning configs at build/ch.admin.bag.covidcertificate.wallet/verifier/build.gradle
2021-09-14 15:39:51,282 INFO: Running 'prebuild' commands in build/ch.admin.bag.covidcertificate.wallet/wallet
2021-09-14 15:39:51,282 DEBUG: Directory: build/ch.admin.bag.covidcertificate.wallet/wallet
2021-09-14 15:39:51,282 DEBUG: > bash -x -c -- printf '\nbuildTimestamp=%s\n' "$(curl -sL https://github.com/admin-ch/CovidCertificate-App-Android/releases/download/v2.5.0-2500-wallet/wallet-prod-2.5.0-2500-buildtimestamp.txt | tr -cd '0-9')" >> gradle.properties
++ curl -sL https://github.com/admin-ch/CovidCertificate-App-Android/releases/download/v2.5.0-2500-wallet/wallet-prod-2.5.0-2500-buildtimestamp.txt
++ tr -cd 0-9
+ printf '\nbuildTimestamp=%s\n' 1631025842122
2021-09-14 15:39:51,889 INFO: Cleaning Gradle project...
2021-09-14 15:39:51,890 DEBUG: Directory: build/ch.admin.bag.covidcertificate.wallet/wallet
2021-09-14 15:39:51,890 DEBUG: > /home/vagrant/fdroidserver/gradlew-fdroid clean
Found 7.0.2 via distributionUrl
Running /opt/gradle/versions/7.0.2/bin/gradle clean

Welcome to Gradle 7.0.2!

Here are the highlights of this release:
 - File system watching enabled by default
 - Support for running with and building Java 16 projects
 - Native support for Apple Silicon processors
 - Dependency catalog feature preview

For more details see https://docs.gradle.org/7.0.2/release-notes.html

To honour the JVM settings for this build a single-use Daemon process will be forked. See https://docs.gradle.org/7.0.2/userguide/gradle_daemon.html#sec:disabling_the_daemon.
Daemon will be stopped at the end of the build 

FAILURE: Build failed with an exception.

* What went wrong:
A problem occurred configuring root project 'CovidCertificate'.
> Could not resolve all artifacts for configuration ':classpath'.
   > Could not resolve ch.ubique.gradle:ubdiag-android:7.0.2.
     Required by:
         project :
      > No matching variant of ch.ubique.gradle:ubdiag-android:7.0.2 was found. The consumer was configured to find a runtime of a library compatible with Java 8, packaged as a jar, and its dependencies declared externally, as well as attribute 'org.gradle.plugin.api-version' with value '7.0.2' but:
          - Variant 'apiElements' capability ch.ubique.gradle:ubdiag-android:7.0.2 declares a library, packaged as a jar, and its dependencies declared externally:
              - Incompatible because this component declares an API of a component compatible with Java 11 and the consumer needed a runtime of a component compatible with Java 8
              - Other compatible attribute:
                  - Doesn't say anything about org.gradle.plugin.api-version (required '7.0.2')
          - Variant 'runtimeElements' capability ch.ubique.gradle:ubdiag-android:7.0.2 declares a runtime of a library, packaged as a jar, and its dependencies declared externally:
              - Incompatible because this component declares a component compatible with Java 11 and the consumer needed a component compatible with Java 8
              - Other compatible attribute:
                  - Doesn't say anything about org.gradle.plugin.api-version (required '7.0.2')

* Try:
Run with --stacktrace option to get the stack trace. Run with --info or --debug option to get more log output. Run with --scan to get full insights.

* Get more help at https://help.gradle.org

BUILD FAILED in 9s
2021-09-14 15:40:02,358 ERROR: Could not build app ch.admin.bag.covidcertificate.wallet: Error cleaning ch.admin.bag.covidcertificate.wallet:2.5.0
==== detail begin ====
Found 7.0.2 via distributionUrl
Running /opt/gradle/versions/7.0.2/bin/gradle clean

Welcome to Gradle 7.0.2!

Here are the highlights of this release:
 - File system watching enabled by default
 - Support for running with and building Java 16 projects
 - Native support for Apple Silicon processors
 - Dependency catalog feature preview

For more details see https://docs.gradle.org/7.0.2/release-notes.html

To honour the JVM settings for this build a single-use Daemon process will be forked. See https://docs.gradle.org/7.0.2/userguide/gradle_daemon.html#sec:disabling_the_daemon.
Daemon will be stopped at the end of the build 

FAILURE: Build failed with an exception.

* What went wrong:
A problem occurred configuring root project 'CovidCertificate'.
> Could not resolve all artifacts for configuration ':classpath'.
   > Could not resolve ch.ubique.gradle:ubdiag-android:7.0.2.
     Required by:
         project :
      > No matching variant of ch.ubique.gradle:ubdiag-android:7.0.2 was found. The consumer was configured to find a runtime of a library compatible with Java 8, packaged as a jar, and its dependencies declared externally, as well as attribute 'org.gradle.plugin.api-version' with value '7.0.2' but:
          - Variant 'apiElements' capability ch.ubique.gradle:ubdiag-android:7.0.2 declares a library, packaged as a jar, and its dependencies declared externally:
              - Incompatible because this component declares an API of a component compatible with Java 11 and the consumer needed a runtime of a component compatible with Java 8
              - Other compatible attribute:
                  - Doesn't say anything about org.gradle.plugin.api-version (required '7.0.2')
          - Variant 'runtimeElements' capability ch.ubique.gradle:ubdiag-android:7.0.2 declares a runtime of a library, packaged as a jar, and its dependencies declared externally:
              - Incompatible because this component declares a component compatible with Java 11 and the consumer needed a component compatible with Java 8
              - Other compatible attribute:
                  - Doesn't say anything about org.gradle.plugin.api-version (required '7.0.2')

* Try:
Run with --stacktrace option to get the stack trace. Run with --info or --debug option to get more log output. Run with --scan to get full insights.

* Get more help at https://help.gradle.org

BUILD FAILED in 9s
==== detail end ====
2021-09-14 15:40:02,358 DEBUG: Error encoutered, stopping by user request.