log for com.btcontract.wallet:76

== Installed Android Tools ==

2021-10-13 17:32:28,775 DEBUG: Reading 'config.yml'
2021-10-13 17:32:28,786 INFO: Using /opt/android-sdk/build-tools/29.0.3/apksigner 
2021-10-13 17:32:28,790 INFO: Creating log directory
2021-10-13 17:32:28,791 INFO: Creating temporary directory
2021-10-13 17:32:28,791 INFO: Creating output directory
2021-10-13 17:32:28,796 DEBUG: Getting git vcs interface for https://github.com/btcontract/wallet.git
2021-10-13 17:32:28,796 DEBUG: > git --version
git version 2.11.0
2021-10-13 17:32:29,012 INFO: Using git version 2.11.0
2021-10-13 17:32:29,013 DEBUG: Checking 2.2.14
2021-10-13 17:32:29,013 INFO: Building version 2.2.14 (76) of com.btcontract.wallet
2021-10-13 17:32:29,014 DEBUG: > sudo passwd --lock root
passwd: password expiry information changed.
2021-10-13 17:32:29,224 DEBUG: > sudo SUDO_FORCE_REMOVE=yes dpkg --purge sudo
(Reading database ... 64914 files and directories currently installed.)
Removing sudo (1.8.19p1-2.1+deb9u3) ...
Purging configuration files for sudo (1.8.19p1-2.1+deb9u3) ...
Processing triggers for systemd (232-25+deb9u13) ...
2021-10-13 17:32:34,730 INFO: Getting source for revision eed44c207574208847b5c31113b84524d95129f1
2021-10-13 17:32:34,730 DEBUG: Directory: build/com.btcontract.wallet
2021-10-13 17:32:34,730 DEBUG: > git rev-parse --show-toplevel
2021-10-13 17:32:34,936 DEBUG: Directory: build/com.btcontract.wallet
2021-10-13 17:32:34,936 DEBUG: > git submodule foreach --recursive git reset --hard
2021-10-13 17:32:36,521 DEBUG: Directory: build/com.btcontract.wallet
2021-10-13 17:32:36,521 DEBUG: > git reset --hard
2021-10-13 17:32:36,728 DEBUG: Directory: build/com.btcontract.wallet
2021-10-13 17:32:36,729 DEBUG: > git submodule foreach --recursive git clean -dffx
2021-10-13 17:32:36,840 DEBUG: Directory: build/com.btcontract.wallet
2021-10-13 17:32:36,840 DEBUG: > git clean -dffx
2021-10-13 17:32:36,944 DEBUG: Directory: build/com.btcontract.wallet
2021-10-13 17:32:36,945 DEBUG: > git -c core.askpass=/bin/true -c core.sshCommand=/bin/false -c url.https://.insteadOf=ssh:// -c url.https://u:p@bitbucket.org/.insteadOf=git@bitbucket.org: -c url.https://u:p@bitbucket.org.insteadOf=git://bitbucket.org -c url.https://u:p@bitbucket.org.insteadOf=https://bitbucket.org -c url.https://u:p@github.com/.insteadOf=git@github.com: -c url.https://u:p@github.com.insteadOf=git://github.com -c url.https://u:p@github.com.insteadOf=https://github.com -c url.https://u:p@gitlab.com/.insteadOf=git@gitlab.com: -c url.https://u:p@gitlab.com.insteadOf=git://gitlab.com -c url.https://u:p@gitlab.com.insteadOf=https://gitlab.com fetch origin
2021-10-13 17:32:37,360 DEBUG: Directory: build/com.btcontract.wallet
2021-10-13 17:32:37,361 DEBUG: > git -c core.askpass=/bin/true -c core.sshCommand=/bin/false -c url.https://.insteadOf=ssh:// -c url.https://u:p@bitbucket.org/.insteadOf=git@bitbucket.org: -c url.https://u:p@bitbucket.org.insteadOf=git://bitbucket.org -c url.https://u:p@bitbucket.org.insteadOf=https://bitbucket.org -c url.https://u:p@github.com/.insteadOf=git@github.com: -c url.https://u:p@github.com.insteadOf=git://github.com -c url.https://u:p@github.com.insteadOf=https://github.com -c url.https://u:p@gitlab.com/.insteadOf=git@gitlab.com: -c url.https://u:p@gitlab.com.insteadOf=git://gitlab.com -c url.https://u:p@gitlab.com.insteadOf=https://gitlab.com fetch --prune --tags --force origin
2021-10-13 17:32:37,669 DEBUG: Directory: build/com.btcontract.wallet
2021-10-13 17:32:37,669 DEBUG: > git remote set-head origin --auto
2021-10-13 17:32:38,077 DEBUG: Directory: build/com.btcontract.wallet
2021-10-13 17:32:38,077 DEBUG: > git checkout -f eed44c207574208847b5c31113b84524d95129f1
2021-10-13 17:32:38,285 DEBUG: Directory: build/com.btcontract.wallet
2021-10-13 17:32:38,286 DEBUG: > git clean -dffx
2021-10-13 17:32:38,391 INFO: Creating local.properties file at build/com.btcontract.wallet/local.properties
2021-10-13 17:32:38,392 INFO: Creating local.properties file at build/com.btcontract.wallet/app/local.properties
2021-10-13 17:32:38,393 DEBUG: Removing debuggable flags from build/com.btcontract.wallet/app
2021-10-13 17:32:38,414 INFO: Cleaning Gradle project...
2021-10-13 17:32:38,414 DEBUG: Directory: build/com.btcontract.wallet/app
2021-10-13 17:32:38,414 DEBUG: > /home/vagrant/fdroidserver/gradlew-fdroid clean
Found 5.4.1 via distributionUrl
Downloading missing gradle version 5.4.1
cachedir /home/vagrant/.cache/fdroidserver
/home/vagrant/.cache/fdroidserver/gradle-5.4.1-bin.zip: OK
Running /opt/gradle/versions/5.4.1/bin/gradle clean

Welcome to Gradle 5.4.1!

Here are the highlights of this release:
 - Run builds with JDK12
 - New API for Incremental Tasks
 - Updates to native projects, including Swift 5 support

For more details see https://docs.gradle.org/5.4.1/release-notes.html

To honour the JVM settings for this build a new JVM will be forked. Please consider using the daemon: https://docs.gradle.org/5.4.1/userguide/gradle_daemon.html.
Daemon will be stopped at the end of the build stopping after processing

> Configure project :app
File /home/vagrant/.android/repositories.cfg could not be loaded.
Checking the license for package Android SDK Build-Tools 30.0.3 in /opt/android-sdk/licenses
License for package Android SDK Build-Tools 30.0.3 accepted.
Preparing "Install Android SDK Build-Tools 30.0.3 (revision: 30.0.3)".
"Install Android SDK Build-Tools 30.0.3 (revision: 30.0.3)" ready.
Installing Android SDK Build-Tools 30.0.3 in /opt/android-sdk/build-tools/30.0.3
"Install Android SDK Build-Tools 30.0.3 (revision: 30.0.3)" complete.
"Install Android SDK Build-Tools 30.0.3 (revision: 30.0.3)" finished.
Checking the license for package Android SDK Platform 30 in /opt/android-sdk/licenses
License for package Android SDK Platform 30 accepted.
Preparing "Install Android SDK Platform 30 (revision: 3)".
"Install Android SDK Platform 30 (revision: 3)" ready.
Installing Android SDK Platform 30 in /opt/android-sdk/platforms/android-30
"Install Android SDK Platform 30 (revision: 3)" complete.
"Install Android SDK Platform 30 (revision: 3)" finished.

> Task :app:externalNativeBuildCleanDebug
Support for ANDROID_NDK_HOME is deprecated and will be removed in the future. Use android.ndkVersion in build.gradle instead.
Checking the license for package CMake 3.6.4111459 in /opt/android-sdk/licenses
License for package CMake 3.6.4111459 accepted.
Preparing "Install CMake 3.6.4111459 (revision: 3.6.4111459)".
"Install CMake 3.6.4111459 (revision: 3.6.4111459)" ready.
Installing CMake 3.6.4111459 in /opt/android-sdk/cmake/3.6.4111459
"Install CMake 3.6.4111459 (revision: 3.6.4111459)" complete.
"Install CMake 3.6.4111459 (revision: 3.6.4111459)" finished.

> Task :app:externalNativeBuildCleanRelease
> Task :app:clean UP-TO-DATE

BUILD SUCCESSFUL in 1m 14s
3 actionable tasks: 2 executed, 1 up-to-date
2021-10-13 17:33:55,918 INFO: Scanning source for common problems...
2021-10-13 17:33:55,922 INFO: Removing gradle-wrapper.jar at gradle/wrapper/gradle-wrapper.jar
2021-10-13 17:33:56,011 INFO: Creating source tarball...
2021-10-13 17:33:56,865 INFO: Building Gradle project...
2021-10-13 17:33:56,865 DEBUG: Directory: build/com.btcontract.wallet/app
2021-10-13 17:33:56,865 DEBUG: > /home/vagrant/fdroidserver/gradlew-fdroid assembleRelease
Found 5.4.1 via distributionUrl
Running /opt/gradle/versions/5.4.1/bin/gradle assembleRelease
To honour the JVM settings for this build a new JVM will be forked. Please consider using the daemon: https://docs.gradle.org/5.4.1/userguide/gradle_daemon.html.
Daemon will be stopped at the end of the build stopping after processing
Support for ANDROID_NDK_HOME is deprecated and will be removed in the future. Use android.ndkVersion in build.gradle instead.
> Task :app:preBuild
> Task :app:preReleaseBuild
> Task :app:compileReleaseAidl NO-SOURCE
> Task :app:checkReleaseManifest
> Task :app:compileReleaseRenderscript NO-SOURCE
> Task :app:generateReleaseBuildConfig
> Task :app:prepareLintJar
> Task :app:prepareLintJarForPublish
> Task :app:generateReleaseSources
> Task :app:mainApkListPersistenceRelease
> Task :app:generateReleaseResValues
> Task :app:generateReleaseResources
> Task :app:createReleaseCompatibleScreenManifests
> Task :app:processReleaseManifest
> Task :app:mergeReleaseResources
> Task :app:processReleaseResources

> Task :app:compileReleaseScala
Pruning sources from previous analysis, due to incompatible CompileSetup.

> Task :app:javaPreCompileRelease

> Task :app:compileReleaseScala
/home/vagrant/build/com.btcontract.wallet/app/src/main/java/com/btcontract/wallet/BaseActivity.scala:55: method fromHtml in object Html is deprecated: see corresponding Javadoc for more information.
    def html: Spanned = android.text.Html.fromHtml(source)
                                          ^
/home/vagrant/build/com.btcontract.wallet/app/src/main/java/com/btcontract/wallet/SetupActivity.scala:98: method startActivityForResult in class ComponentActivity is deprecated: see corresponding Javadoc for more information.
  def useBackupFile(view: View): Unit = startActivityForResult(new Intent(Intent.ACTION_OPEN_DOCUMENT).setType("*/*"), FILE_REQUEST_CODE)
                                        ^
/home/vagrant/build/com.btcontract.wallet/app/src/main/java/com/btcontract/wallet/WalletApp.scala:320: method vibrate in class Vibrator is deprecated: see corresponding Javadoc for more information.
  def vibrate: Unit = if (null != vibrator && vibrator.hasVibrator) vibrator.vibrate(Array(0L, 85, 200), -1)
                                                                             ^
/home/vagrant/build/com.btcontract.wallet/app/src/main/java/com/btcontract/wallet/utils/BiometricAuth.scala:20: method canAuthenticate in class BiometricManager is deprecated: see corresponding Javadoc for more information.
  def checkAuth: Unit = biometricManager.canAuthenticate match {
                                         ^
/home/vagrant/build/com.btcontract.wallet/app/src/main/java/com/btcontract/wallet/utils/BiometricAuth.scala:32: method setDeviceCredentialAllowed in class Builder is deprecated: see corresponding Javadoc for more information.
        .setDeviceCredentialAllowed(true)
         ^
/home/vagrant/build/com.btcontract.wallet/app/src/main/java/com/btcontract/wallet/utils/LocalBackup.scala:39: method getExternalStoragePublicDirectory in object Environment is deprecated: see corresponding Javadoc for more information.
  def downloadsDir: File = getExternalStoragePublicDirectory(DIRECTORY_DOWNLOADS)
                           ^
there were 17 feature warnings; re-run with -feature for details
7 warnings found
Note: Some input files use or override a deprecated API.
Note: Recompile with -Xlint:deprecation for details.
Note: Some input files use unchecked or unsafe operations.
Note: Recompile with -Xlint:unchecked for details.

> Task :app:compileReleaseJavaWithJavac
Note: Some input files use or override a deprecated API.
Note: Recompile with -Xlint:deprecation for details.
Note: Some input files use unchecked or unsafe operations.
Note: Recompile with -Xlint:unchecked for details.

> Task :app:generateJsonModelRelease
release|armeabi-v7a :CMake Warning at /opt/android-sdk/ndk/22.1.7171670/build/cmake/android.toolchain.cmake:449 (message):
release|armeabi-v7a :  An old version of CMake is being used that cannot automatically detect
release|armeabi-v7a :  compiler attributes.  Compiler identification is being bypassed.  Some
release|armeabi-v7a :  values may be wrong or missing.  Update to CMake 3.19 or newer to use
release|armeabi-v7a :  CMake's built-in compiler identification.
release|armeabi-v7a :Call Stack (most recent call first):
release|armeabi-v7a :  /opt/android-sdk/cmake/3.6.4111459/share/cmake-3.6/Modules/CMakeDetermineSystem.cmake:98 (include)
release|armeabi-v7a :  CMakeLists.txt
release|armeabi-v7a :-- Check for working C compiler: /opt/android-sdk/ndk/22.1.7171670/toolchains/llvm/prebuilt/linux-x86_64/bin/clang
release|armeabi-v7a :CMake Warning at /opt/android-sdk/ndk/22.1.7171670/build/cmake/android.toolchain.cmake:449 (message):
release|armeabi-v7a :  An old version of CMake is being used that cannot automatically detect
release|armeabi-v7a :  compiler attributes.  Compiler identification is being bypassed.  Some
release|armeabi-v7a :  values may be wrong or missing.  Update to CMake 3.19 or newer to use
release|armeabi-v7a :  CMake's built-in compiler identification.
release|armeabi-v7a :Call Stack (most recent call first):
release|armeabi-v7a :  /home/vagrant/build/com.btcontract.wallet/app/.cxx/cmake/release/armeabi-v7a/CMakeFiles/3.6.0-rc2/CMakeSystem.cmake:6 (include)
release|armeabi-v7a :  /home/vagrant/build/com.btcontract.wallet/app/.cxx/cmake/release/armeabi-v7a/CMakeFiles/CMakeTmp/CMakeLists.txt:2 (project)
release|armeabi-v7a :-- Check for working C compiler: /opt/android-sdk/ndk/22.1.7171670/toolchains/llvm/prebuilt/linux-x86_64/bin/clang -- works
release|armeabi-v7a :-- Detecting C compiler ABI info
release|armeabi-v7a :CMake Warning at /opt/android-sdk/ndk/22.1.7171670/build/cmake/android.toolchain.cmake:449 (message):
release|armeabi-v7a :  An old version of CMake is being used that cannot automatically detect
release|armeabi-v7a :  compiler attributes.  Compiler identification is being bypassed.  Some
release|armeabi-v7a :  values may be wrong or missing.  Update to CMake 3.19 or newer to use
release|armeabi-v7a :  CMake's built-in compiler identification.
release|armeabi-v7a :Call Stack (most recent call first):
release|armeabi-v7a :  /home/vagrant/build/com.btcontract.wallet/app/.cxx/cmake/release/armeabi-v7a/CMakeFiles/3.6.0-rc2/CMakeSystem.cmake:6 (include)
release|armeabi-v7a :  /home/vagrant/build/com.btcontract.wallet/app/.cxx/cmake/release/armeabi-v7a/CMakeFiles/CMakeTmp/CMakeLists.txt:2 (project)
release|armeabi-v7a :-- Detecting C compiler ABI info - done
release|armeabi-v7a :-- Detecting C compile features
release|armeabi-v7a :CMake Warning at /opt/android-sdk/ndk/22.1.7171670/build/cmake/android.toolchain.cmake:449 (message):
release|armeabi-v7a :  An old version of CMake is being used that cannot automatically detect
release|armeabi-v7a :  compiler attributes.  Compiler identification is being bypassed.  Some
release|armeabi-v7a :  values may be wrong or missing.  Update to CMake 3.19 or newer to use
release|armeabi-v7a :  CMake's built-in compiler identification.
release|armeabi-v7a :Call Stack (most recent call first):
release|armeabi-v7a :  /home/vagrant/build/com.btcontract.wallet/app/.cxx/cmake/release/armeabi-v7a/CMakeFiles/3.6.0-rc2/CMakeSystem.cmake:6 (include)
release|armeabi-v7a :  /home/vagrant/build/com.btcontract.wallet/app/.cxx/cmake/release/armeabi-v7a/CMakeFiles/CMakeTmp/CMakeLists.txt:2 (project)
release|armeabi-v7a :CMake Warning at /opt/android-sdk/ndk/22.1.7171670/build/cmake/android.toolchain.cmake:449 (message):
release|armeabi-v7a :  An old version of CMake is being used that cannot automatically detect
release|armeabi-v7a :  compiler attributes.  Compiler identification is being bypassed.  Some
release|armeabi-v7a :  values may be wrong or missing.  Update to CMake 3.19 or newer to use
release|armeabi-v7a :  CMake's built-in compiler identification.
release|armeabi-v7a :Call Stack (most recent call first):
release|armeabi-v7a :  /home/vagrant/build/com.btcontract.wallet/app/.cxx/cmake/release/armeabi-v7a/CMakeFiles/3.6.0-rc2/CMakeSystem.cmake:6 (include)
release|armeabi-v7a :  /home/vagrant/build/com.btcontract.wallet/app/.cxx/cmake/release/armeabi-v7a/CMakeFiles/CMakeTmp/CMakeLists.txt:2 (project)
release|armeabi-v7a :CMake Warning at /opt/android-sdk/ndk/22.1.7171670/build/cmake/android.toolchain.cmake:449 (message):
release|armeabi-v7a :  An old version of CMake is being used that cannot automatically detect
release|armeabi-v7a :  compiler attributes.  Compiler identification is being bypassed.  Some
release|armeabi-v7a :  values may be wrong or missing.  Update to CMake 3.19 or newer to use
release|armeabi-v7a :  CMake's built-in compiler identification.
release|armeabi-v7a :Call Stack (most recent call first):
release|armeabi-v7a :  /home/vagrant/build/com.btcontract.wallet/app/.cxx/cmake/release/armeabi-v7a/CMakeFiles/3.6.0-rc2/CMakeSystem.cmake:6 (include)
release|armeabi-v7a :  /home/vagrant/build/com.btcontract.wallet/app/.cxx/cmake/release/armeabi-v7a/CMakeFiles/CMakeTmp/CMakeLists.txt:2 (project)
release|armeabi-v7a :-- Detecting C compile features - done
release|armeabi-v7a :-- Check for working CXX compiler: /opt/android-sdk/ndk/22.1.7171670/toolchains/llvm/prebuilt/linux-x86_64/bin/clang++
release|armeabi-v7a :CMake Warning at /opt/android-sdk/ndk/22.1.7171670/build/cmake/android.toolchain.cmake:449 (message):
release|armeabi-v7a :  An old version of CMake is being used that cannot automatically detect
release|armeabi-v7a :  compiler attributes.  Compiler identification is being bypassed.  Some
release|armeabi-v7a :  values may be wrong or missing.  Update to CMake 3.19 or newer to use
release|armeabi-v7a :  CMake's built-in compiler identification.
release|armeabi-v7a :Call Stack (most recent call first):
release|armeabi-v7a :  /home/vagrant/build/com.btcontract.wallet/app/.cxx/cmake/release/armeabi-v7a/CMakeFiles/3.6.0-rc2/CMakeSystem.cmake:6 (include)
release|armeabi-v7a :  /home/vagrant/build/com.btcontract.wallet/app/.cxx/cmake/release/armeabi-v7a/CMakeFiles/CMakeTmp/CMakeLists.txt:2 (project)
release|armeabi-v7a :-- Check for working CXX compiler: /opt/android-sdk/ndk/22.1.7171670/toolchains/llvm/prebuilt/linux-x86_64/bin/clang++ -- works
release|armeabi-v7a :-- Detecting CXX compiler ABI info
release|armeabi-v7a :CMake Warning at /opt/android-sdk/ndk/22.1.7171670/build/cmake/android.toolchain.cmake:449 (message):
release|armeabi-v7a :  An old version of CMake is being used that cannot automatically detect
release|armeabi-v7a :  compiler attributes.  Compiler identification is being bypassed.  Some
release|armeabi-v7a :  values may be wrong or missing.  Update to CMake 3.19 or newer to use
release|armeabi-v7a :  CMake's built-in compiler identification.
release|armeabi-v7a :Call Stack (most recent call first):
release|armeabi-v7a :  /home/vagrant/build/com.btcontract.wallet/app/.cxx/cmake/release/armeabi-v7a/CMakeFiles/3.6.0-rc2/CMakeSystem.cmake:6 (include)
release|armeabi-v7a :  /home/vagrant/build/com.btcontract.wallet/app/.cxx/cmake/release/armeabi-v7a/CMakeFiles/CMakeTmp/CMakeLists.txt:2 (project)
release|armeabi-v7a :-- Detecting CXX compiler ABI info - done
release|armeabi-v7a :-- Detecting CXX compile features
release|armeabi-v7a :CMake Warning at /opt/android-sdk/ndk/22.1.7171670/build/cmake/android.toolchain.cmake:449 (message):
release|armeabi-v7a :  An old version of CMake is being used that cannot automatically detect
release|armeabi-v7a :  compiler attributes.  Compiler identification is being bypassed.  Some
release|armeabi-v7a :  values may be wrong or missing.  Update to CMake 3.19 or newer to use
release|armeabi-v7a :  CMake's built-in compiler identification.
release|armeabi-v7a :Call Stack (most recent call first):
release|armeabi-v7a :  /home/vagrant/build/com.btcontract.wallet/app/.cxx/cmake/release/armeabi-v7a/CMakeFiles/3.6.0-rc2/CMakeSystem.cmake:6 (include)
release|armeabi-v7a :  /home/vagrant/build/com.btcontract.wallet/app/.cxx/cmake/release/armeabi-v7a/CMakeFiles/CMakeTmp/CMakeLists.txt:2 (project)
release|armeabi-v7a :CMake Warning at /opt/android-sdk/ndk/22.1.7171670/build/cmake/android.toolchain.cmake:449 (message):
release|armeabi-v7a :  An old version of CMake is being used that cannot automatically detect
release|armeabi-v7a :  compiler attributes.  Compiler identification is being bypassed.  Some
release|armeabi-v7a :  values may be wrong or missing.  Update to CMake 3.19 or newer to use
release|armeabi-v7a :  CMake's built-in compiler identification.
release|armeabi-v7a :Call Stack (most recent call first):
release|armeabi-v7a :  /home/vagrant/build/com.btcontract.wallet/app/.cxx/cmake/release/armeabi-v7a/CMakeFiles/3.6.0-rc2/CMakeSystem.cmake:6 (include)
release|armeabi-v7a :  /home/vagrant/build/com.btcontract.wallet/app/.cxx/cmake/release/armeabi-v7a/CMakeFiles/CMakeTmp/CMakeLists.txt:2 (project)
release|armeabi-v7a :CMake Warning at /opt/android-sdk/ndk/22.1.7171670/build/cmake/android.toolchain.cmake:449 (message):
release|armeabi-v7a :  An old version of CMake is being used that cannot automatically detect
release|armeabi-v7a :  compiler attributes.  Compiler identification is being bypassed.  Some
release|armeabi-v7a :  values may be wrong or missing.  Update to CMake 3.19 or newer to use
release|armeabi-v7a :  CMake's built-in compiler identification.
release|armeabi-v7a :Call Stack (most recent call first):
release|armeabi-v7a :  /home/vagrant/build/com.btcontract.wallet/app/.cxx/cmake/release/armeabi-v7a/CMakeFiles/3.6.0-rc2/CMakeSystem.cmake:6 (include)
release|armeabi-v7a :  /home/vagrant/build/com.btcontract.wallet/app/.cxx/cmake/release/armeabi-v7a/CMakeFiles/CMakeTmp/CMakeLists.txt:2 (project)
release|armeabi-v7a :-- Detecting CXX compile features - done
release|armeabi-v7a :-- Configuring done
release|armeabi-v7a :-- Generating done
release|armeabi-v7a :-- Build files have been written to: /home/vagrant/build/com.btcontract.wallet/app/.cxx/cmake/release/armeabi-v7a
release|arm64-v8a :CMake Warning at /opt/android-sdk/ndk/22.1.7171670/build/cmake/android.toolchain.cmake:449 (message):
release|arm64-v8a :  An old version of CMake is being used that cannot automatically detect
release|arm64-v8a :  compiler attributes.  Compiler identification is being bypassed.  Some
release|arm64-v8a :  values may be wrong or missing.  Update to CMake 3.19 or newer to use
release|arm64-v8a :  CMake's built-in compiler identification.
release|arm64-v8a :Call Stack (most recent call first):
release|arm64-v8a :  /opt/android-sdk/cmake/3.6.4111459/share/cmake-3.6/Modules/CMakeDetermineSystem.cmake:98 (include)
release|arm64-v8a :  CMakeLists.txt
release|arm64-v8a :-- Check for working C compiler: /opt/android-sdk/ndk/22.1.7171670/toolchains/llvm/prebuilt/linux-x86_64/bin/clang
release|arm64-v8a :CMake Warning at /opt/android-sdk/ndk/22.1.7171670/build/cmake/android.toolchain.cmake:449 (message):
release|arm64-v8a :  An old version of CMake is being used that cannot automatically detect
release|arm64-v8a :  compiler attributes.  Compiler identification is being bypassed.  Some
release|arm64-v8a :  values may be wrong or missing.  Update to CMake 3.19 or newer to use
release|arm64-v8a :  CMake's built-in compiler identification.
release|arm64-v8a :Call Stack (most recent call first):
release|arm64-v8a :  /home/vagrant/build/com.btcontract.wallet/app/.cxx/cmake/release/arm64-v8a/CMakeFiles/3.6.0-rc2/CMakeSystem.cmake:6 (include)
release|arm64-v8a :  /home/vagrant/build/com.btcontract.wallet/app/.cxx/cmake/release/arm64-v8a/CMakeFiles/CMakeTmp/CMakeLists.txt:2 (project)
release|arm64-v8a :-- Check for working C compiler: /opt/android-sdk/ndk/22.1.7171670/toolchains/llvm/prebuilt/linux-x86_64/bin/clang -- works
release|arm64-v8a :-- Detecting C compiler ABI info
release|arm64-v8a :CMake Warning at /opt/android-sdk/ndk/22.1.7171670/build/cmake/android.toolchain.cmake:449 (message):
release|arm64-v8a :  An old version of CMake is being used that cannot automatically detect
release|arm64-v8a :  compiler attributes.  Compiler identification is being bypassed.  Some
release|arm64-v8a :  values may be wrong or missing.  Update to CMake 3.19 or newer to use
release|arm64-v8a :  CMake's built-in compiler identification.
release|arm64-v8a :Call Stack (most recent call first):
release|arm64-v8a :  /home/vagrant/build/com.btcontract.wallet/app/.cxx/cmake/release/arm64-v8a/CMakeFiles/3.6.0-rc2/CMakeSystem.cmake:6 (include)
release|arm64-v8a :  /home/vagrant/build/com.btcontract.wallet/app/.cxx/cmake/release/arm64-v8a/CMakeFiles/CMakeTmp/CMakeLists.txt:2 (project)
release|arm64-v8a :-- Detecting C compiler ABI info - done
release|arm64-v8a :-- Detecting C compile features
release|arm64-v8a :CMake Warning at /opt/android-sdk/ndk/22.1.7171670/build/cmake/android.toolchain.cmake:449 (message):
release|arm64-v8a :  An old version of CMake is being used that cannot automatically detect
release|arm64-v8a :  compiler attributes.  Compiler identification is being bypassed.  Some
release|arm64-v8a :  values may be wrong or missing.  Update to CMake 3.19 or newer to use
release|arm64-v8a :  CMake's built-in compiler identification.
release|arm64-v8a :Call Stack (most recent call first):
release|arm64-v8a :  /home/vagrant/build/com.btcontract.wallet/app/.cxx/cmake/release/arm64-v8a/CMakeFiles/3.6.0-rc2/CMakeSystem.cmake:6 (include)
release|arm64-v8a :  /home/vagrant/build/com.btcontract.wallet/app/.cxx/cmake/release/arm64-v8a/CMakeFiles/CMakeTmp/CMakeLists.txt:2 (project)
release|arm64-v8a :CMake Warning at /opt/android-sdk/ndk/22.1.7171670/build/cmake/android.toolchain.cmake:449 (message):
release|arm64-v8a :  An old version of CMake is being used that cannot automatically detect
release|arm64-v8a :  compiler attributes.  Compiler identification is being bypassed.  Some
release|arm64-v8a :  values may be wrong or missing.  Update to CMake 3.19 or newer to use
release|arm64-v8a :  CMake's built-in compiler identification.
release|arm64-v8a :Call Stack (most recent call first):
release|arm64-v8a :  /home/vagrant/build/com.btcontract.wallet/app/.cxx/cmake/release/arm64-v8a/CMakeFiles/3.6.0-rc2/CMakeSystem.cmake:6 (include)
release|arm64-v8a :  /home/vagrant/build/com.btcontract.wallet/app/.cxx/cmake/release/arm64-v8a/CMakeFiles/CMakeTmp/CMakeLists.txt:2 (project)
release|arm64-v8a :CMake Warning at /opt/android-sdk/ndk/22.1.7171670/build/cmake/android.toolchain.cmake:449 (message):
release|arm64-v8a :  An old version of CMake is being used that cannot automatically detect
release|arm64-v8a :  compiler attributes.  Compiler identification is being bypassed.  Some
release|arm64-v8a :  values may be wrong or missing.  Update to CMake 3.19 or newer to use
release|arm64-v8a :  CMake's built-in compiler identification.
release|arm64-v8a :Call Stack (most recent call first):
release|arm64-v8a :  /home/vagrant/build/com.btcontract.wallet/app/.cxx/cmake/release/arm64-v8a/CMakeFiles/3.6.0-rc2/CMakeSystem.cmake:6 (include)
release|arm64-v8a :  /home/vagrant/build/com.btcontract.wallet/app/.cxx/cmake/release/arm64-v8a/CMakeFiles/CMakeTmp/CMakeLists.txt:2 (project)
release|arm64-v8a :-- Detecting C compile features - done
release|arm64-v8a :-- Check for working CXX compiler: /opt/android-sdk/ndk/22.1.7171670/toolchains/llvm/prebuilt/linux-x86_64/bin/clang++
release|arm64-v8a :CMake Warning at /opt/android-sdk/ndk/22.1.7171670/build/cmake/android.toolchain.cmake:449 (message):
release|arm64-v8a :  An old version of CMake is being used that cannot automatically detect
release|arm64-v8a :  compiler attributes.  Compiler identification is being bypassed.  Some
release|arm64-v8a :  values may be wrong or missing.  Update to CMake 3.19 or newer to use
release|arm64-v8a :  CMake's built-in compiler identification.
release|arm64-v8a :Call Stack (most recent call first):
release|arm64-v8a :  /home/vagrant/build/com.btcontract.wallet/app/.cxx/cmake/release/arm64-v8a/CMakeFiles/3.6.0-rc2/CMakeSystem.cmake:6 (include)
release|arm64-v8a :  /home/vagrant/build/com.btcontract.wallet/app/.cxx/cmake/release/arm64-v8a/CMakeFiles/CMakeTmp/CMakeLists.txt:2 (project)
release|arm64-v8a :-- Check for working CXX compiler: /opt/android-sdk/ndk/22.1.7171670/toolchains/llvm/prebuilt/linux-x86_64/bin/clang++ -- works
release|arm64-v8a :-- Detecting CXX compiler ABI info
release|arm64-v8a :CMake Warning at /opt/android-sdk/ndk/22.1.7171670/build/cmake/android.toolchain.cmake:449 (message):
release|arm64-v8a :  An old version of CMake is being used that cannot automatically detect
release|arm64-v8a :  compiler attributes.  Compiler identification is being bypassed.  Some
release|arm64-v8a :  values may be wrong or missing.  Update to CMake 3.19 or newer to use
release|arm64-v8a :  CMake's built-in compiler identification.
release|arm64-v8a :Call Stack (most recent call first):
release|arm64-v8a :  /home/vagrant/build/com.btcontract.wallet/app/.cxx/cmake/release/arm64-v8a/CMakeFiles/3.6.0-rc2/CMakeSystem.cmake:6 (include)
release|arm64-v8a :  /home/vagrant/build/com.btcontract.wallet/app/.cxx/cmake/release/arm64-v8a/CMakeFiles/CMakeTmp/CMakeLists.txt:2 (project)
release|arm64-v8a :-- Detecting CXX compiler ABI info - done
release|arm64-v8a :-- Detecting CXX compile features
release|arm64-v8a :CMake Warning at /opt/android-sdk/ndk/22.1.7171670/build/cmake/android.toolchain.cmake:449 (message):
release|arm64-v8a :  An old version of CMake is being used that cannot automatically detect
release|arm64-v8a :  compiler attributes.  Compiler identification is being bypassed.  Some
release|arm64-v8a :  values may be wrong or missing.  Update to CMake 3.19 or newer to use
release|arm64-v8a :  CMake's built-in compiler identification.
release|arm64-v8a :Call Stack (most recent call first):
release|arm64-v8a :  /home/vagrant/build/com.btcontract.wallet/app/.cxx/cmake/release/arm64-v8a/CMakeFiles/3.6.0-rc2/CMakeSystem.cmake:6 (include)
release|arm64-v8a :  /home/vagrant/build/com.btcontract.wallet/app/.cxx/cmake/release/arm64-v8a/CMakeFiles/CMakeTmp/CMakeLists.txt:2 (project)
release|arm64-v8a :CMake Warning at /opt/android-sdk/ndk/22.1.7171670/build/cmake/android.toolchain.cmake:449 (message):
release|arm64-v8a :  An old version of CMake is being used that cannot automatically detect
release|arm64-v8a :  compiler attributes.  Compiler identification is being bypassed.  Some
release|arm64-v8a :  values may be wrong or missing.  Update to CMake 3.19 or newer to use
release|arm64-v8a :  CMake's built-in compiler identification.
release|arm64-v8a :Call Stack (most recent call first):
release|arm64-v8a :  /home/vagrant/build/com.btcontract.wallet/app/.cxx/cmake/release/arm64-v8a/CMakeFiles/3.6.0-rc2/CMakeSystem.cmake:6 (include)
release|arm64-v8a :  /home/vagrant/build/com.btcontract.wallet/app/.cxx/cmake/release/arm64-v8a/CMakeFiles/CMakeTmp/CMakeLists.txt:2 (project)
release|arm64-v8a :CMake Warning at /opt/android-sdk/ndk/22.1.7171670/build/cmake/android.toolchain.cmake:449 (message):
release|arm64-v8a :  An old version of CMake is being used that cannot automatically detect
release|arm64-v8a :  compiler attributes.  Compiler identification is being bypassed.  Some
release|arm64-v8a :  values may be wrong or missing.  Update to CMake 3.19 or newer to use
release|arm64-v8a :  CMake's built-in compiler identification.
release|arm64-v8a :Call Stack (most recent call first):
release|arm64-v8a :  /home/vagrant/build/com.btcontract.wallet/app/.cxx/cmake/release/arm64-v8a/CMakeFiles/3.6.0-rc2/CMakeSystem.cmake:6 (include)
release|arm64-v8a :  /home/vagrant/build/com.btcontract.wallet/app/.cxx/cmake/release/arm64-v8a/CMakeFiles/CMakeTmp/CMakeLists.txt:2 (project)
release|arm64-v8a :-- Detecting CXX compile features - done
release|arm64-v8a :-- Configuring done
release|arm64-v8a :-- Generating done
release|arm64-v8a :-- Build files have been written to: /home/vagrant/build/com.btcontract.wallet/app/.cxx/cmake/release/arm64-v8a
release|x86 :CMake Warning at /opt/android-sdk/ndk/22.1.7171670/build/cmake/android.toolchain.cmake:449 (message):
release|x86 :  An old version of CMake is being used that cannot automatically detect
release|x86 :  compiler attributes.  Compiler identification is being bypassed.  Some
release|x86 :  values may be wrong or missing.  Update to CMake 3.19 or newer to use
release|x86 :  CMake's built-in compiler identification.
release|x86 :Call Stack (most recent call first):
release|x86 :  /opt/android-sdk/cmake/3.6.4111459/share/cmake-3.6/Modules/CMakeDetermineSystem.cmake:98 (include)
release|x86 :  CMakeLists.txt
release|x86 :-- Check for working C compiler: /opt/android-sdk/ndk/22.1.7171670/toolchains/llvm/prebuilt/linux-x86_64/bin/clang
release|x86 :CMake Warning at /opt/android-sdk/ndk/22.1.7171670/build/cmake/android.toolchain.cmake:449 (message):
release|x86 :  An old version of CMake is being used that cannot automatically detect
release|x86 :  compiler attributes.  Compiler identification is being bypassed.  Some
release|x86 :  values may be wrong or missing.  Update to CMake 3.19 or newer to use
release|x86 :  CMake's built-in compiler identification.
release|x86 :Call Stack (most recent call first):
release|x86 :  /home/vagrant/build/com.btcontract.wallet/app/.cxx/cmake/release/x86/CMakeFiles/3.6.0-rc2/CMakeSystem.cmake:6 (include)
release|x86 :  /home/vagrant/build/com.btcontract.wallet/app/.cxx/cmake/release/x86/CMakeFiles/CMakeTmp/CMakeLists.txt:2 (project)
release|x86 :-- Check for working C compiler: /opt/android-sdk/ndk/22.1.7171670/toolchains/llvm/prebuilt/linux-x86_64/bin/clang -- works
release|x86 :-- Detecting C compiler ABI info
release|x86 :CMake Warning at /opt/android-sdk/ndk/22.1.7171670/build/cmake/android.toolchain.cmake:449 (message):
release|x86 :  An old version of CMake is being used that cannot automatically detect
release|x86 :  compiler attributes.  Compiler identification is being bypassed.  Some
release|x86 :  values may be wrong or missing.  Update to CMake 3.19 or newer to use
release|x86 :  CMake's built-in compiler identification.
release|x86 :Call Stack (most recent call first):
release|x86 :  /home/vagrant/build/com.btcontract.wallet/app/.cxx/cmake/release/x86/CMakeFiles/3.6.0-rc2/CMakeSystem.cmake:6 (include)
release|x86 :  /home/vagrant/build/com.btcontract.wallet/app/.cxx/cmake/release/x86/CMakeFiles/CMakeTmp/CMakeLists.txt:2 (project)
release|x86 :-- Detecting C compiler ABI info - done
release|x86 :-- Detecting C compile features
release|x86 :CMake Warning at /opt/android-sdk/ndk/22.1.7171670/build/cmake/android.toolchain.cmake:449 (message):
release|x86 :  An old version of CMake is being used that cannot automatically detect
release|x86 :  compiler attributes.  Compiler identification is being bypassed.  Some
release|x86 :  values may be wrong or missing.  Update to CMake 3.19 or newer to use
release|x86 :  CMake's built-in compiler identification.
release|x86 :Call Stack (most recent call first):
release|x86 :  /home/vagrant/build/com.btcontract.wallet/app/.cxx/cmake/release/x86/CMakeFiles/3.6.0-rc2/CMakeSystem.cmake:6 (include)
release|x86 :  /home/vagrant/build/com.btcontract.wallet/app/.cxx/cmake/release/x86/CMakeFiles/CMakeTmp/CMakeLists.txt:2 (project)
release|x86 :CMake Warning at /opt/android-sdk/ndk/22.1.7171670/build/cmake/android.toolchain.cmake:449 (message):
release|x86 :  An old version of CMake is being used that cannot automatically detect
release|x86 :  compiler attributes.  Compiler identification is being bypassed.  Some
release|x86 :  values may be wrong or missing.  Update to CMake 3.19 or newer to use
release|x86 :  CMake's built-in compiler identification.
release|x86 :Call Stack (most recent call first):
release|x86 :  /home/vagrant/build/com.btcontract.wallet/app/.cxx/cmake/release/x86/CMakeFiles/3.6.0-rc2/CMakeSystem.cmake:6 (include)
release|x86 :  /home/vagrant/build/com.btcontract.wallet/app/.cxx/cmake/release/x86/CMakeFiles/CMakeTmp/CMakeLists.txt:2 (project)
release|x86 :CMake Warning at /opt/android-sdk/ndk/22.1.7171670/build/cmake/android.toolchain.cmake:449 (message):
release|x86 :  An old version of CMake is being used that cannot automatically detect
release|x86 :  compiler attributes.  Compiler identification is being bypassed.  Some
release|x86 :  values may be wrong or missing.  Update to CMake 3.19 or newer to use
release|x86 :  CMake's built-in compiler identification.
release|x86 :Call Stack (most recent call first):
release|x86 :  /home/vagrant/build/com.btcontract.wallet/app/.cxx/cmake/release/x86/CMakeFiles/3.6.0-rc2/CMakeSystem.cmake:6 (include)
release|x86 :  /home/vagrant/build/com.btcontract.wallet/app/.cxx/cmake/release/x86/CMakeFiles/CMakeTmp/CMakeLists.txt:2 (project)
release|x86 :-- Detecting C compile features - done
release|x86 :-- Check for working CXX compiler: /opt/android-sdk/ndk/22.1.7171670/toolchains/llvm/prebuilt/linux-x86_64/bin/clang++
release|x86 :CMake Warning at /opt/android-sdk/ndk/22.1.7171670/build/cmake/android.toolchain.cmake:449 (message):
release|x86 :  An old version of CMake is being used that cannot automatically detect
release|x86 :  compiler attributes.  Compiler identification is being bypassed.  Some
release|x86 :  values may be wrong or missing.  Update to CMake 3.19 or newer to use
release|x86 :  CMake's built-in compiler identification.
release|x86 :Call Stack (most recent call first):
release|x86 :  /home/vagrant/build/com.btcontract.wallet/app/.cxx/cmake/release/x86/CMakeFiles/3.6.0-rc2/CMakeSystem.cmake:6 (include)
release|x86 :  /home/vagrant/build/com.btcontract.wallet/app/.cxx/cmake/release/x86/CMakeFiles/CMakeTmp/CMakeLists.txt:2 (project)
release|x86 :-- Check for working CXX compiler: /opt/android-sdk/ndk/22.1.7171670/toolchains/llvm/prebuilt/linux-x86_64/bin/clang++ -- works
release|x86 :-- Detecting CXX compiler ABI info
release|x86 :CMake Warning at /opt/android-sdk/ndk/22.1.7171670/build/cmake/android.toolchain.cmake:449 (message):
release|x86 :  An old version of CMake is being used that cannot automatically detect
release|x86 :  compiler attributes.  Compiler identification is being bypassed.  Some
release|x86 :  values may be wrong or missing.  Update to CMake 3.19 or newer to use
release|x86 :  CMake's built-in compiler identification.
release|x86 :Call Stack (most recent call first):
release|x86 :  /home/vagrant/build/com.btcontract.wallet/app/.cxx/cmake/release/x86/CMakeFiles/3.6.0-rc2/CMakeSystem.cmake:6 (include)
release|x86 :  /home/vagrant/build/com.btcontract.wallet/app/.cxx/cmake/release/x86/CMakeFiles/CMakeTmp/CMakeLists.txt:2 (project)
release|x86 :-- Detecting CXX compiler ABI info - done
release|x86 :-- Detecting CXX compile features
release|x86 :CMake Warning at /opt/android-sdk/ndk/22.1.7171670/build/cmake/android.toolchain.cmake:449 (message):
release|x86 :  An old version of CMake is being used that cannot automatically detect
release|x86 :  compiler attributes.  Compiler identification is being bypassed.  Some
release|x86 :  values may be wrong or missing.  Update to CMake 3.19 or newer to use
release|x86 :  CMake's built-in compiler identification.
release|x86 :Call Stack (most recent call first):
release|x86 :  /home/vagrant/build/com.btcontract.wallet/app/.cxx/cmake/release/x86/CMakeFiles/3.6.0-rc2/CMakeSystem.cmake:6 (include)
release|x86 :  /home/vagrant/build/com.btcontract.wallet/app/.cxx/cmake/release/x86/CMakeFiles/CMakeTmp/CMakeLists.txt:2 (project)
release|x86 :CMake Warning at /opt/android-sdk/ndk/22.1.7171670/build/cmake/android.toolchain.cmake:449 (message):
release|x86 :  An old version of CMake is being used that cannot automatically detect
release|x86 :  compiler attributes.  Compiler identification is being bypassed.  Some
release|x86 :  values may be wrong or missing.  Update to CMake 3.19 or newer to use
release|x86 :  CMake's built-in compiler identification.
release|x86 :Call Stack (most recent call first):
release|x86 :  /home/vagrant/build/com.btcontract.wallet/app/.cxx/cmake/release/x86/CMakeFiles/3.6.0-rc2/CMakeSystem.cmake:6 (include)
release|x86 :  /home/vagrant/build/com.btcontract.wallet/app/.cxx/cmake/release/x86/CMakeFiles/CMakeTmp/CMakeLists.txt:2 (project)
release|x86 :CMake Warning at /opt/android-sdk/ndk/22.1.7171670/build/cmake/android.toolchain.cmake:449 (message):
release|x86 :  An old version of CMake is being used that cannot automatically detect
release|x86 :  compiler attributes.  Compiler identification is being bypassed.  Some
release|x86 :  values may be wrong or missing.  Update to CMake 3.19 or newer to use
release|x86 :  CMake's built-in compiler identification.
release|x86 :Call Stack (most recent call first):
release|x86 :  /home/vagrant/build/com.btcontract.wallet/app/.cxx/cmake/release/x86/CMakeFiles/3.6.0-rc2/CMakeSystem.cmake:6 (include)
release|x86 :  /home/vagrant/build/com.btcontract.wallet/app/.cxx/cmake/release/x86/CMakeFiles/CMakeTmp/CMakeLists.txt:2 (project)
release|x86 :-- Detecting CXX compile features - done
release|x86 :-- Configuring done
release|x86 :-- Generating done
release|x86 :-- Build files have been written to: /home/vagrant/build/com.btcontract.wallet/app/.cxx/cmake/release/x86
release|x86_64 :CMake Warning at /opt/android-sdk/ndk/22.1.7171670/build/cmake/android.toolchain.cmake:449 (message):
release|x86_64 :  An old version of CMake is being used that cannot automatically detect
release|x86_64 :  compiler attributes.  Compiler identification is being bypassed.  Some
release|x86_64 :  values may be wrong or missing.  Update to CMake 3.19 or newer to use
release|x86_64 :  CMake's built-in compiler identification.
release|x86_64 :Call Stack (most recent call first):
release|x86_64 :  /opt/android-sdk/cmake/3.6.4111459/share/cmake-3.6/Modules/CMakeDetermineSystem.cmake:98 (include)
release|x86_64 :  CMakeLists.txt
release|x86_64 :-- Check for working C compiler: /opt/android-sdk/ndk/22.1.7171670/toolchains/llvm/prebuilt/linux-x86_64/bin/clang
release|x86_64 :CMake Warning at /opt/android-sdk/ndk/22.1.7171670/build/cmake/android.toolchain.cmake:449 (message):
release|x86_64 :  An old version of CMake is being used that cannot automatically detect
release|x86_64 :  compiler attributes.  Compiler identification is being bypassed.  Some
release|x86_64 :  values may be wrong or missing.  Update to CMake 3.19 or newer to use
release|x86_64 :  CMake's built-in compiler identification.
release|x86_64 :Call Stack (most recent call first):
release|x86_64 :  /home/vagrant/build/com.btcontract.wallet/app/.cxx/cmake/release/x86_64/CMakeFiles/3.6.0-rc2/CMakeSystem.cmake:6 (include)
release|x86_64 :  /home/vagrant/build/com.btcontract.wallet/app/.cxx/cmake/release/x86_64/CMakeFiles/CMakeTmp/CMakeLists.txt:2 (project)
release|x86_64 :-- Check for working C compiler: /opt/android-sdk/ndk/22.1.7171670/toolchains/llvm/prebuilt/linux-x86_64/bin/clang -- works
release|x86_64 :-- Detecting C compiler ABI info
release|x86_64 :CMake Warning at /opt/android-sdk/ndk/22.1.7171670/build/cmake/android.toolchain.cmake:449 (message):
release|x86_64 :  An old version of CMake is being used that cannot automatically detect
release|x86_64 :  compiler attributes.  Compiler identification is being bypassed.  Some
release|x86_64 :  values may be wrong or missing.  Update to CMake 3.19 or newer to use
release|x86_64 :  CMake's built-in compiler identification.
release|x86_64 :Call Stack (most recent call first):
release|x86_64 :  /home/vagrant/build/com.btcontract.wallet/app/.cxx/cmake/release/x86_64/CMakeFiles/3.6.0-rc2/CMakeSystem.cmake:6 (include)
release|x86_64 :  /home/vagrant/build/com.btcontract.wallet/app/.cxx/cmake/release/x86_64/CMakeFiles/CMakeTmp/CMakeLists.txt:2 (project)
release|x86_64 :-- Detecting C compiler ABI info - done
release|x86_64 :-- Detecting C compile features
release|x86_64 :CMake Warning at /opt/android-sdk/ndk/22.1.7171670/build/cmake/android.toolchain.cmake:449 (message):
release|x86_64 :  An old version of CMake is being used that cannot automatically detect
release|x86_64 :  compiler attributes.  Compiler identification is being bypassed.  Some
release|x86_64 :  values may be wrong or missing.  Update to CMake 3.19 or newer to use
release|x86_64 :  CMake's built-in compiler identification.
release|x86_64 :Call Stack (most recent call first):
release|x86_64 :  /home/vagrant/build/com.btcontract.wallet/app/.cxx/cmake/release/x86_64/CMakeFiles/3.6.0-rc2/CMakeSystem.cmake:6 (include)
release|x86_64 :  /home/vagrant/build/com.btcontract.wallet/app/.cxx/cmake/release/x86_64/CMakeFiles/CMakeTmp/CMakeLists.txt:2 (project)
release|x86_64 :CMake Warning at /opt/android-sdk/ndk/22.1.7171670/build/cmake/android.toolchain.cmake:449 (message):
release|x86_64 :  An old version of CMake is being used that cannot automatically detect
release|x86_64 :  compiler attributes.  Compiler identification is being bypassed.  Some
release|x86_64 :  values may be wrong or missing.  Update to CMake 3.19 or newer to use
release|x86_64 :  CMake's built-in compiler identification.
release|x86_64 :Call Stack (most recent call first):
release|x86_64 :  /home/vagrant/build/com.btcontract.wallet/app/.cxx/cmake/release/x86_64/CMakeFiles/3.6.0-rc2/CMakeSystem.cmake:6 (include)
release|x86_64 :  /home/vagrant/build/com.btcontract.wallet/app/.cxx/cmake/release/x86_64/CMakeFiles/CMakeTmp/CMakeLists.txt:2 (project)
release|x86_64 :CMake Warning at /opt/android-sdk/ndk/22.1.7171670/build/cmake/android.toolchain.cmake:449 (message):
release|x86_64 :  An old version of CMake is being used that cannot automatically detect
release|x86_64 :  compiler attributes.  Compiler identification is being bypassed.  Some
release|x86_64 :  values may be wrong or missing.  Update to CMake 3.19 or newer to use
release|x86_64 :  CMake's built-in compiler identification.
release|x86_64 :Call Stack (most recent call first):
release|x86_64 :  /home/vagrant/build/com.btcontract.wallet/app/.cxx/cmake/release/x86_64/CMakeFiles/3.6.0-rc2/CMakeSystem.cmake:6 (include)
release|x86_64 :  /home/vagrant/build/com.btcontract.wallet/app/.cxx/cmake/release/x86_64/CMakeFiles/CMakeTmp/CMakeLists.txt:2 (project)
release|x86_64 :-- Detecting C compile features - done
release|x86_64 :-- Check for working CXX compiler: /opt/android-sdk/ndk/22.1.7171670/toolchains/llvm/prebuilt/linux-x86_64/bin/clang++
release|x86_64 :CMake Warning at /opt/android-sdk/ndk/22.1.7171670/build/cmake/android.toolchain.cmake:449 (message):
release|x86_64 :  An old version of CMake is being used that cannot automatically detect
release|x86_64 :  compiler attributes.  Compiler identification is being bypassed.  Some
release|x86_64 :  values may be wrong or missing.  Update to CMake 3.19 or newer to use
release|x86_64 :  CMake's built-in compiler identification.
release|x86_64 :Call Stack (most recent call first):
release|x86_64 :  /home/vagrant/build/com.btcontract.wallet/app/.cxx/cmake/release/x86_64/CMakeFiles/3.6.0-rc2/CMakeSystem.cmake:6 (include)
release|x86_64 :  /home/vagrant/build/com.btcontract.wallet/app/.cxx/cmake/release/x86_64/CMakeFiles/CMakeTmp/CMakeLists.txt:2 (project)
release|x86_64 :-- Check for working CXX compiler: /opt/android-sdk/ndk/22.1.7171670/toolchains/llvm/prebuilt/linux-x86_64/bin/clang++ -- works
release|x86_64 :-- Detecting CXX compiler ABI info
release|x86_64 :CMake Warning at /opt/android-sdk/ndk/22.1.7171670/build/cmake/android.toolchain.cmake:449 (message):
release|x86_64 :  An old version of CMake is being used that cannot automatically detect
release|x86_64 :  compiler attributes.  Compiler identification is being bypassed.  Some
release|x86_64 :  values may be wrong or missing.  Update to CMake 3.19 or newer to use
release|x86_64 :  CMake's built-in compiler identification.
release|x86_64 :Call Stack (most recent call first):
release|x86_64 :  /home/vagrant/build/com.btcontract.wallet/app/.cxx/cmake/release/x86_64/CMakeFiles/3.6.0-rc2/CMakeSystem.cmake:6 (include)
release|x86_64 :  /home/vagrant/build/com.btcontract.wallet/app/.cxx/cmake/release/x86_64/CMakeFiles/CMakeTmp/CMakeLists.txt:2 (project)
release|x86_64 :-- Detecting CXX compiler ABI info - done
release|x86_64 :-- Detecting CXX compile features
release|x86_64 :CMake Warning at /opt/android-sdk/ndk/22.1.7171670/build/cmake/android.toolchain.cmake:449 (message):
release|x86_64 :  An old version of CMake is being used that cannot automatically detect
release|x86_64 :  compiler attributes.  Compiler identification is being bypassed.  Some
release|x86_64 :  values may be wrong or missing.  Update to CMake 3.19 or newer to use
release|x86_64 :  CMake's built-in compiler identification.
release|x86_64 :Call Stack (most recent call first):
release|x86_64 :  /home/vagrant/build/com.btcontract.wallet/app/.cxx/cmake/release/x86_64/CMakeFiles/3.6.0-rc2/CMakeSystem.cmake:6 (include)
release|x86_64 :  /home/vagrant/build/com.btcontract.wallet/app/.cxx/cmake/release/x86_64/CMakeFiles/CMakeTmp/CMakeLists.txt:2 (project)
release|x86_64 :CMake Warning at /opt/android-sdk/ndk/22.1.7171670/build/cmake/android.toolchain.cmake:449 (message):
release|x86_64 :  An old version of CMake is being used that cannot automatically detect
release|x86_64 :  compiler attributes.  Compiler identification is being bypassed.  Some
release|x86_64 :  values may be wrong or missing.  Update to CMake 3.19 or newer to use
release|x86_64 :  CMake's built-in compiler identification.
release|x86_64 :Call Stack (most recent call first):
release|x86_64 :  /home/vagrant/build/com.btcontract.wallet/app/.cxx/cmake/release/x86_64/CMakeFiles/3.6.0-rc2/CMakeSystem.cmake:6 (include)
release|x86_64 :  /home/vagrant/build/com.btcontract.wallet/app/.cxx/cmake/release/x86_64/CMakeFiles/CMakeTmp/CMakeLists.txt:2 (project)
release|x86_64 :CMake Warning at /opt/android-sdk/ndk/22.1.7171670/build/cmake/android.toolchain.cmake:449 (message):
release|x86_64 :  An old version of CMake is being used that cannot automatically detect
release|x86_64 :  compiler attributes.  Compiler identification is being bypassed.  Some
release|x86_64 :  values may be wrong or missing.  Update to CMake 3.19 or newer to use
release|x86_64 :  CMake's built-in compiler identification.
release|x86_64 :Call Stack (most recent call first):
release|x86_64 :  /home/vagrant/build/com.btcontract.wallet/app/.cxx/cmake/release/x86_64/CMakeFiles/3.6.0-rc2/CMakeSystem.cmake:6 (include)
release|x86_64 :  /home/vagrant/build/com.btcontract.wallet/app/.cxx/cmake/release/x86_64/CMakeFiles/CMakeTmp/CMakeLists.txt:2 (project)
release|x86_64 :-- Detecting CXX compile features - done
release|x86_64 :-- Configuring done
release|x86_64 :-- Generating done
release|x86_64 :-- Build files have been written to: /home/vagrant/build/com.btcontract.wallet/app/.cxx/cmake/release/x86_64

> Task :app:externalNativeBuildRelease
Build secp256k1_armeabi-v7a
[1/4] Building C object CMakeFiles/secp256k1.dir/src/main/cpp/secp256k1/src/secp256k1.c.o
[2/4] Building C object CMakeFiles/secp256k1.dir/src/main/cpp/secp256k1/src/org_bitcoin_NativeSecp256k1.c.o
[3/4] Building C object CMakeFiles/secp256k1.dir/src/main/cpp/secp256k1/src/org_bitcoin_Secp256k1Context.c.o
[4/4] Linking C shared library ../../../../build/intermediates/cmake/release/obj/armeabi-v7a/libsecp256k1.so
Build secp256k1_arm64-v8a
[1/4] Building C object CMakeFiles/secp256k1.dir/src/main/cpp/secp256k1/src/org_bitcoin_NativeSecp256k1.c.o
[2/4] Building C object CMakeFiles/secp256k1.dir/src/main/cpp/secp256k1/src/secp256k1.c.o
[3/4] Building C object CMakeFiles/secp256k1.dir/src/main/cpp/secp256k1/src/org_bitcoin_Secp256k1Context.c.o
[4/4] Linking C shared library ../../../../build/intermediates/cmake/release/obj/arm64-v8a/libsecp256k1.so
Build secp256k1_x86
[1/4] Building C object CMakeFiles/secp256k1.dir/src/main/cpp/secp256k1/src/org_bitcoin_NativeSecp256k1.c.o
[2/4] Building C object CMakeFiles/secp256k1.dir/src/main/cpp/secp256k1/src/secp256k1.c.o
[3/4] Building C object CMakeFiles/secp256k1.dir/src/main/cpp/secp256k1/src/org_bitcoin_Secp256k1Context.c.o
[4/4] Linking C shared library ../../../../build/intermediates/cmake/release/obj/x86/libsecp256k1.so
Build secp256k1_x86_64
[1/4] Building C object CMakeFiles/secp256k1.dir/src/main/cpp/secp256k1/src/org_bitcoin_NativeSecp256k1.c.o
[2/4] Building C object CMakeFiles/secp256k1.dir/src/main/cpp/secp256k1/src/secp256k1.c.o
[3/4] Building C object CMakeFiles/secp256k1.dir/src/main/cpp/secp256k1/src/org_bitcoin_Secp256k1Context.c.o
[4/4] Linking C shared library ../../../../build/intermediates/cmake/release/obj/x86_64/libsecp256k1.so

> Task :app:compileReleaseSources

> Task :app:lintVitalRelease
Calling mockable JAR artifact transform to create file: /home/vagrant/.gradle/caches/transforms-2/files-2.1/8df7eb9fbd62cc73cc19cec929d80e1e/android.jar with input /opt/android-sdk/platforms/android-30/android.jar

> Task :app:checkReleaseDuplicateClasses
> Task :app:transformClassesWithDexBuilderForRelease
> Task :app:desugarReleaseFileDependencies
> Task :app:mergeReleaseShaders
> Task :app:compileReleaseShaders
> Task :app:generateReleaseAssets
> Task :app:mergeReleaseAssets
> Task :app:processReleaseJavaRes NO-SOURCE
> Task :app:signingConfigWriterRelease
> Task :app:mergeReleaseJniLibFolders
> Task :app:mergeReleaseNativeLibs
> Task :app:stripReleaseDebugSymbols
> Task :app:mergeReleaseJavaResource
> Task :app:mergeExtDexRelease
> Task :app:mergeDexRelease
> Task :app:packageRelease
> Task :app:assembleRelease

Deprecated Gradle features were used in this build, making it incompatible with Gradle 6.0.
Use '--warning-mode all' to show the individual deprecation warnings.
See https://docs.gradle.org/5.4.1/userguide/command_line_interface.html#sec:command_line_warnings

BUILD SUCCESSFUL in 3m 37s
31 actionable tasks: 31 executed
2021-10-13 17:37:35,737 DEBUG: Popen(['git', 'cat-file', '--batch-check'], cwd=/home/vagrant/build/com.btcontract.wallet, universal_newlines=False, shell=None)
2021-10-13 17:37:35,740 INFO: Successfully built version 2.2.14 of com.btcontract.wallet from eed44c207574208847b5c31113b84524d95129f1
2021-10-13 17:37:36,853 DEBUG: AXML contains a RESOURCE MAP
2021-10-13 17:37:36,853 DEBUG: Start of Namespace mapping: prefix 43: 'android' --> uri 121: 'http://schemas.android.com/apk/res/android'
2021-10-13 17:37:36,855 DEBUG: Checking build/com.btcontract.wallet/app/build/outputs/apk/release/SBW-2.2.14.apk
2021-10-13 17:37:36,865 DEBUG: AXML contains a RESOURCE MAP
2021-10-13 17:37:36,865 DEBUG: Start of Namespace mapping: prefix 43: 'android' --> uri 121: 'http://schemas.android.com/apk/res/android'
2021-10-13 17:37:36,895 INFO: success: com.btcontract.wallet
2021-10-13 17:37:36,895 INFO: Finished
2021-10-13 17:37:36,895 INFO: 1 build succeeded