log for com.jonjomckay.fritter:20210910

== Installed Android Tools ==

2021-09-15 15:13:30,112 DEBUG: Reading 'config.yml'
2021-09-15 15:13:30,121 INFO: Using /opt/android-sdk/build-tools/29.0.3/apksigner 
2021-09-15 15:13:30,124 INFO: Creating log directory
2021-09-15 15:13:30,125 INFO: Creating temporary directory
2021-09-15 15:13:30,125 INFO: Creating output directory
2021-09-15 15:13:30,145 DEBUG: Getting git vcs interface for https://github.com/jonjomckay/fritter
2021-09-15 15:13:30,145 DEBUG: > git --version
git version 2.11.0
2021-09-15 15:13:30,372 INFO: Using git version 2.11.0
2021-09-15 15:13:30,372 DEBUG: Checking 2.14.0
2021-09-15 15:13:30,373 INFO: Building version 2.14.0 (20210910) of com.jonjomckay.fritter
2021-09-15 15:13:30,374 DEBUG: > sudo passwd --lock root
passwd: password expiry information changed.
2021-09-15 15:13:31,357 DEBUG: > sudo SUDO_FORCE_REMOVE=yes dpkg --purge sudo
(Reading database ... 64894 files and directories currently installed.)
Removing sudo (1.8.19p1-2.1+deb9u3) ...
Purging configuration files for sudo (1.8.19p1-2.1+deb9u3) ...
Processing triggers for systemd (232-25+deb9u13) ...
2021-09-15 15:13:36,684 INFO: Getting source for revision fc42370039eb509a68020f9f5ecdf7d2a5305997
2021-09-15 15:13:36,685 DEBUG: Directory: build/com.jonjomckay.fritter
2021-09-15 15:13:36,685 DEBUG: > git rev-parse --show-toplevel
2021-09-15 15:13:36,893 DEBUG: Directory: build/com.jonjomckay.fritter
2021-09-15 15:13:36,893 DEBUG: > git submodule foreach --recursive git reset --hard
2021-09-15 15:13:40,360 DEBUG: Directory: build/com.jonjomckay.fritter
2021-09-15 15:13:40,360 DEBUG: > git reset --hard
2021-09-15 15:13:40,670 DEBUG: Directory: build/com.jonjomckay.fritter
2021-09-15 15:13:40,670 DEBUG: > git submodule foreach --recursive git clean -dffx
2021-09-15 15:13:40,775 DEBUG: Directory: build/com.jonjomckay.fritter
2021-09-15 15:13:40,776 DEBUG: > git clean -dffx
2021-09-15 15:13:40,890 DEBUG: Directory: build/com.jonjomckay.fritter
2021-09-15 15:13:40,890 DEBUG: > git -c core.askpass=/bin/true -c core.sshCommand=/bin/false -c url.https://.insteadOf=ssh:// -c url.https://u:p@bitbucket.org/.insteadOf=git@bitbucket.org: -c url.https://u:p@bitbucket.org.insteadOf=git://bitbucket.org -c url.https://u:p@bitbucket.org.insteadOf=https://bitbucket.org -c url.https://u:p@github.com/.insteadOf=git@github.com: -c url.https://u:p@github.com.insteadOf=git://github.com -c url.https://u:p@github.com.insteadOf=https://github.com -c url.https://u:p@gitlab.com/.insteadOf=git@gitlab.com: -c url.https://u:p@gitlab.com.insteadOf=git://gitlab.com -c url.https://u:p@gitlab.com.insteadOf=https://gitlab.com fetch origin
2021-09-15 15:13:41,296 DEBUG: Directory: build/com.jonjomckay.fritter
2021-09-15 15:13:41,296 DEBUG: > git -c core.askpass=/bin/true -c core.sshCommand=/bin/false -c url.https://.insteadOf=ssh:// -c url.https://u:p@bitbucket.org/.insteadOf=git@bitbucket.org: -c url.https://u:p@bitbucket.org.insteadOf=git://bitbucket.org -c url.https://u:p@bitbucket.org.insteadOf=https://bitbucket.org -c url.https://u:p@github.com/.insteadOf=git@github.com: -c url.https://u:p@github.com.insteadOf=git://github.com -c url.https://u:p@github.com.insteadOf=https://github.com -c url.https://u:p@gitlab.com/.insteadOf=git@gitlab.com: -c url.https://u:p@gitlab.com.insteadOf=git://gitlab.com -c url.https://u:p@gitlab.com.insteadOf=https://gitlab.com fetch --prune --tags --force origin
2021-09-15 15:13:41,602 DEBUG: Directory: build/com.jonjomckay.fritter
2021-09-15 15:13:41,602 DEBUG: > git remote set-head origin --auto
2021-09-15 15:13:42,009 DEBUG: Directory: build/com.jonjomckay.fritter
2021-09-15 15:13:42,009 DEBUG: > git checkout -f fc42370039eb509a68020f9f5ecdf7d2a5305997
2021-09-15 15:13:42,220 DEBUG: Directory: build/com.jonjomckay.fritter
2021-09-15 15:13:42,220 DEBUG: > git clean -dffx
2021-09-15 15:13:42,325 INFO: Collecting source libraries
2021-09-15 15:13:42,403 DEBUG: Removing debuggable flags from build/srclib/flutter
2021-09-15 15:13:42,452 INFO: Creating local.properties file at build/com.jonjomckay.fritter/local.properties
2021-09-15 15:13:42,452 DEBUG: Removing debuggable flags from build/com.jonjomckay.fritter
2021-09-15 15:13:42,460 INFO: Removing specified files
2021-09-15 15:13:42,461 INFO: Removing ios
2021-09-15 15:13:42,463 INFO: Removing test
2021-09-15 15:13:42,464 INFO: Cleaned build.gradle of keysigning configs at build/com.jonjomckay.fritter/android/app/build.gradle
2021-09-15 15:13:42,479 INFO: Scanning source for common problems...
2021-09-15 15:13:42,491 INFO: Creating source tarball...
2021-09-15 15:13:42,653 INFO: Running 'build' commands in build/com.jonjomckay.fritter
2021-09-15 15:13:42,653 DEBUG: Directory: build/com.jonjomckay.fritter
2021-09-15 15:13:42,654 DEBUG: > bash -x -c /home/vagrant/build/srclib/flutter/bin/flutter config --no-analytics && /home/vagrant/build/srclib/flutter/bin/flutter packages pub get && /home/vagrant/build/srclib/flutter/bin/flutter packages pub run flutter_oss_licenses:generate.dart && /home/vagrant/build/srclib/flutter/bin/flutter build apk
+ /home/vagrant/build/srclib/flutter/bin/flutter config --no-analytics
Downloading Dart SDK from Flutter engine 0fdb562ac8068ce3dda6b69aca3f355f4d1d2718...
  % Total    % Received % Xferd  Average Speed   Time    Time     Time  Current
                                 Dload  Upload   Total   Spent    Left  Speed

  0     0    0     0    0     0      0      0 --:--:-- --:--:-- --:--:--     0
  0     0    0     0    0     0      0      0 --:--:-- --:--:-- --:--:--     0
  4  199M    4 9263k    0     0  6533k      0  0:00:31  0:00:01  0:00:30 6533k
 19  199M   19 38.8M    0     0  17.7M      0  0:00:11  0:00:02  0:00:09 17.7M
 50  199M   50  101M    0     0  31.7M      0  0:00:06  0:00:03  0:00:03 31.7M
100  199M  100  199M    0     0  48.1M      0  0:00:04  0:00:04 --:--:-- 48.1M
Building flutter tool...

  ╔════════════════════════════════════════════════════════════════════════════╗
  ║                 Welcome to Flutter! - https://flutter.dev                  ║
  ║                                                                            ║
  ║ The Flutter tool uses Google Analytics to anonymously report feature usage ║
  ║ statistics and basic crash reports. This data is used to help improve      ║
  ║ Flutter tools over time.                                                   ║
  ║                                                                            ║
  ║ Flutter tool analytics are not sent on the very first run. To disable      ║
  ║ reporting, type 'flutter config --no-analytics'. To display the current    ║
  ║ setting, type 'flutter config'. If you opt out of analytics, an opt-out    ║
  ║ event will be sent, and then no further information will be sent by the    ║
  ║ Flutter tool.                                                              ║
  ║                                                                            ║
  ║ By downloading the Flutter SDK, you agree to the Google Terms of Service.  ║
  ║ Note: The Google Privacy Policy describes how data is handled in this      ║
  ║ service.                                                                   ║
  ║                                                                            ║
  ║ Moreover, Flutter includes the Dart SDK, which may send usage metrics and  ║
  ║ crash reports to Google.                                                   ║
  ║                                                                            ║
  ║ Read about data we send with crash reports:                                ║
  ║ https://flutter.dev/docs/reference/crash-reporting                         ║
  ║                                                                            ║
  ║ See Google's privacy policy:                                               ║
  ║ https://policies.google.com/privacy                                        ║
  ╚════════════════════════════════════════════════════════════════════════════╝

Analytics reporting disabled.

You may need to restart any open editors for them to read new settings.
+ /home/vagrant/build/srclib/flutter/bin/flutter packages pub get
Downloading Material fonts...                                      434ms
Downloading Gradle Wrapper...                                       16ms
Downloading package sky_engine...                                  245ms
Downloading flutter_patched_sdk tools...                           364ms
Downloading flutter_patched_sdk_product tools...                   353ms
Downloading linux-x64 tools...                                   1,344ms
Downloading linux-x64/font-subset tools...                         276ms
Resolving dependencies...
  args 2.0.0 (2.3.0 available)
  async 2.6.1 (2.8.2 available)
  catcher 0.6.6 (0.6.8 available)
  characters 1.1.0 (1.2.0 available)
  charcode 1.2.0 (1.3.1 available)
  convert 3.0.0 (3.0.1 available)
  crypto 3.0.0 (3.0.1 available)
  dart_twitter_api 0.5.1 (0.5.3 available)
  device_info 2.0.0 (2.0.2 available)
  device_info_plus 1.0.1 (2.1.0 available)
  device_info_plus_linux 1.0.1 (2.1.0 available)
  device_info_plus_macos 1.0.1 (2.1.0 available)
  device_info_plus_platform_interface 1.0.2 (2.1.0 available)
  device_info_plus_web 1.0.1 (2.1.0 available)
  device_info_plus_windows 1.0.1 (2.1.0 available)
  dotted_border 2.0.0-nullsafety.0 (2.0.0+1 available)
  extended_image 4.0.1 (4.2.1 available)
  extended_image_library 3.0.0 (3.1.0 available)
  faker 2.0.0-rc.2 (2.0.0 available)
  ffi 1.0.0 (1.1.2 available)
  file 6.1.0 (6.1.2 available)
  flex_color_scheme 2.1.1 (3.0.1 available)
  flutter_launcher_icons 0.9.0 (0.9.2 available)
  flutter_local_notifications 5.0.0+4 (8.2.0 available)
  flutter_local_notifications_platform_interface 3.0.0 (4.0.1 available)
  fluttertoast 8.0.7 (8.0.8 available)
  freezed_annotation 0.14.2 (0.14.3 available)
  http 0.13.1 (0.13.3 available)
  image 3.0.2 (3.0.4 available)
  infinite_scroll_pagination 3.0.1 (3.1.0 available)
  json_annotation 4.0.1 (4.1.0 available)
  logging 1.0.1 (1.0.2 available)
  mailer 5.0.0 (5.0.2 available)
  matcher 0.12.10 (0.12.11 available)
  meta 1.3.0 (1.7.0 available)
  package_info 2.0.0 (2.0.2 available)
  package_info_plus 1.0.1 (1.0.6 available)
  package_info_plus_linux 1.0.2 (1.0.3 available)
  package_info_plus_platform_interface 1.0.1 (1.0.2 available)
  package_info_plus_web 1.0.1 (1.0.4 available)
  package_info_plus_windows 1.0.1 (1.0.3 available)
  path_provider 2.0.1 (2.0.3 available)
  path_provider_linux 2.0.0 (2.1.0 available)
  path_provider_macos 2.0.0 (2.0.2 available)
  path_provider_windows 2.0.0 (2.0.3 available)
  pedantic 1.11.0 (1.11.1 available)
  petitparser 4.0.2 (4.3.0 available)
  platform 3.0.0 (3.0.2 available)
  plugin_platform_interface 2.0.0 (2.0.1 available)
  pref 2.0.2 (2.4.0 available)
  process 4.2.1 (4.2.3 available)
  provider 5.0.0 (6.0.0 available)
  reactive_forms 10.1.0 (10.6.0 available)
  sentry 5.1.0 (6.0.0 available)
  sentry_flutter 5.1.0 (6.0.0 available)
  share 2.0.1 (2.0.4 available)
  shared_preferences 2.0.5 (2.0.7 available)
  shared_preferences_linux 2.0.0 (2.0.2 available)
  shared_preferences_macos 2.0.0 (2.0.2 available)
  shared_preferences_web 2.0.0 (2.0.2 available)
  shared_preferences_windows 2.0.0 (2.0.2 available)
  simple_icons 4.22.0 (5.14.0 available)
  sqflite 2.0.0+3 (2.0.0+4 available)
  sqflite_common 2.0.0+2 (2.0.1+1 available)
  test_api 0.3.0 (0.4.3 available)
  timeago 3.0.2 (3.1.0 available)
  timezone 0.7.0 (0.8.0 available)
  url_launcher 6.0.3 (6.0.10 available)
  url_launcher_linux 2.0.0 (2.0.2 available)
  url_launcher_macos 2.0.0 (2.0.2 available)
  url_launcher_platform_interface 2.0.2 (2.0.4 available)
  url_launcher_web 2.0.0 (2.0.4 available)
  url_launcher_windows 2.0.0 (2.0.2 available)
  video_player 2.1.6 (2.2.0 available)
  video_player_platform_interface 4.1.0 (4.2.0 available)
  video_player_web 2.0.0 (2.0.4 available)
  wakelock 0.5.2 (0.5.6 available)
  wakelock_macos 0.1.0+1 (0.4.0 available)
  wakelock_platform_interface 0.2.1+1 (0.3.0 available)
  wakelock_web 0.2.0+1 (0.4.0 available)
  wakelock_windows 0.1.0 (0.2.0 available)
  win32 2.0.5 (2.2.9 available)
  xml 5.0.2 (5.3.0 available)
Downloading flutter_oss_licenses 1.0.1...
Downloading flutter_launcher_icons 0.9.0...
Downloading cupertino_icons 1.0.3...
Downloading url_launcher 6.0.3...
Downloading uni_links2 0.6.0+2...
Downloading timeago 3.0.2...
Downloading sqflite_migration_plan 0.1.0...
Downloading sqflite 2.0.0+3...
Downloading simple_icons 4.22.0...
Downloading share 2.0.1...
Downloading sentry_flutter 5.1.0...
Downloading reactive_forms 10.1.0...
Downloading quiver 3.0.1...
Downloading pref 2.0.2...
Downloading package_info 2.0.0...
Downloading multi_select_flutter 4.0.0...
Downloading infinite_scroll_pagination 3.0.1...
Downloading http 0.13.1...
Downloading html_unescape 2.0.0...
Downloading flutter_local_notifications 5.0.0+4...
Downloading flex_color_scheme 2.1.1...
Downloading ffcache 1.0.0...
Downloading faker 2.0.0-rc.2...
Downloading extended_image 4.0.1...
Downloading dotted_border 2.0.0-nullsafety.0...
Downloading device_preview 0.7.4...
Downloading device_info 2.0.0...
Downloading dart_twitter_api 0.5.1...
Downloading chewie 1.2.2...
Downloading catcher 0.6.6...
Downloading auto_direction 0.0.5...
Downloading provider 5.0.0...
Downloading image 3.0.2...
Downloading args 2.0.0...
Downloading characters 1.1.0...
Downloading vector_math 2.1.0...
Downloading crypto 3.0.0...
Downloading url_launcher_web 2.0.0...
Downloading url_launcher_windows 2.0.0...
Downloading url_launcher_macos 2.0.0...
Downloading url_launcher_linux 2.0.0...
Downloading url_launcher_platform_interface 2.0.2...
Downloading uni_links_web2 0.1.0+2...
Downloading uni_links2_platform_interface 1.0.0+2...
Downloading sqflite_common 2.0.0+2...
Downloading package_info_plus 1.0.1...
Downloading sentry 5.1.0...
Downloading shared_preferences 2.0.5...
Downloading sliver_tools 0.2.5...
Downloading timezone 0.7.0...
Downloading flutter_local_notifications_platform_interface 3.0.0...
Downloading path_provider 2.0.1...
Downloading synchronized 3.0.0...
Downloading extended_image_library 3.0.0...
Downloading path_drawing 0.5.1...
Downloading freezed_annotation 0.14.2...
Downloading font_awesome_flutter 9.1.0...
Downloading device_frame 0.4.2...
Downloading device_info_platform_interface 2.0.1...
Downloading oauth1 2.0.0...
Downloading wakelock 0.5.2...
Downloading video_player 2.1.6...
Downloading universal_io 2.0.4...
Downloading flutter_mailer 2.0.0...
Downloading dio 4.0.0...
Downloading mailer 5.0.0...
Downloading device_info_plus_platform_interface 1.0.2...
Downloading device_info_plus 1.0.1...
Downloading fluttertoast 8.0.7...
Downloading nested 1.0.0...
Downloading xml 5.0.2...
Downloading plugin_platform_interface 2.0.0...
Downloading package_info_plus_web 1.0.1...
Downloading package_info_plus_windows 1.0.1...
Downloading package_info_plus_macos 1.1.1...
Downloading package_info_plus_linux 1.0.2...
Downloading package_info_plus_platform_interface 1.0.1...
Downloading shared_preferences_windows 2.0.0...
Downloading shared_preferences_web 2.0.0...
Downloading shared_preferences_macos 2.0.0...
Downloading shared_preferences_linux 2.0.0...
Downloading shared_preferences_platform_interface 2.0.0...
Downloading path_provider_windows 2.0.0...
Downloading path_provider_linux 2.0.0...
Downloading path_provider_macos 2.0.0...
Downloading path_provider_platform_interface 2.0.1...
Downloading http_client_helper 2.0.2...
Downloading path_parsing 0.2.1...
Downloading flutter_svg 0.22.0...
Downloading wakelock_windows 0.1.0...
Downloading wakelock_web 0.2.0+1...
Downloading wakelock_platform_interface 0.2.1+1...
Downloading wakelock_macos 0.1.0+1...
Downloading video_player_web 2.0.0...
Downloading video_player_platform_interface 4.1.0...
Downloading device_info_plus_windows 1.0.1...
Downloading device_info_plus_web 1.0.1...
Downloading device_info_plus_macos 1.0.1...
Downloading device_info_plus_linux 1.0.1...
Downloading petitparser 4.0.2...
Downloading win32 2.0.5...
Downloading ffi 1.0.0...
Downloading xdg_directories 0.2.0...
Got dependencies!
+ /home/vagrant/build/srclib/flutter/bin/flutter packages pub run flutter_oss_licenses:generate.dart
+ /home/vagrant/build/srclib/flutter/bin/flutter build apk
Downloading android-arm-profile/linux-x64 tools...                 495ms
Downloading android-arm-release/linux-x64 tools...                 264ms
Downloading android-arm64-profile/linux-x64 tools...               278ms
Downloading android-arm64-release/linux-x64 tools...               243ms
Downloading android-x64-profile/linux-x64 tools...                 260ms
Downloading android-x64-release/linux-x64 tools...                 225ms
Running "flutter pub get" in com.jonjomckay.fritter...           1,418ms

💪 Building with sound null safety 💪

Running Gradle task 'assembleRelease'...                        
Checking the license for package Android SDK Platform 30 in /opt/android-sdk/licenses

License for package Android SDK Platform 30 accepted.

Preparing "Install Android SDK Platform 30 (revision: 3)".

"Install Android SDK Platform 30 (revision: 3)" ready.

Installing Android SDK Platform 30 in /opt/android-sdk/platforms/android-30

"Install Android SDK Platform 30 (revision: 3)" complete.

"Install Android SDK Platform 30 (revision: 3)" finished.

Note: /home/vagrant/.pub-cache/hosted/pub.dartlang.org/device_info_plus-1.0.1/android/src/main/java/dev/fluttercommunity/plus/device_info/DeviceInfoPlusPlugin.java uses or overrides a deprecated API.

Note: Recompile with -Xlint:deprecation for details.

Note: /home/vagrant/.pub-cache/hosted/pub.dartlang.org/flutter_mailer-2.0.0/android/src/main/java/com/dataxad/flutter_mailer/FlutterMailerPlugin.java uses or overrides a deprecated API.

Note: Recompile with -Xlint:deprecation for details.

Note: /home/vagrant/.pub-cache/hosted/pub.dartlang.org/package_info_plus-1.0.1/android/src/main/java/dev/fluttercommunity/plus/packageinfo/PackageInfoPlugin.java uses or overrides a deprecated API.

Note: Recompile with -Xlint:deprecation for details.

Note: /home/vagrant/.pub-cache/hosted/pub.dartlang.org/flutter_local_notifications-5.0.0+4/android/src/main/java/com/dexterous/flutterlocalnotifications/FlutterLocalNotificationsPlugin.java uses or overrides a deprecated API.

Note: Recompile with -Xlint:deprecation for details.

Note: /home/vagrant/.pub-cache/hosted/pub.dartlang.org/uni_links2-0.6.0+2/android/src/main/java/name/avioli/unilinks/UniLinksPlugin.java uses or overrides a deprecated API.

Note: Recompile with -Xlint:deprecation for details.

WARNING: [Processor] Library '/home/vagrant/.gradle/caches/modules-2/files-2.1/org.robolectric/shadows-framework/4.3/150103d5732c432906f6130b734e7452855dd67b/shadows-framework-4.3.jar' contains references to both AndroidX and old support library. This seems like the library is partially migrated. Jetifier will try to rewrite the library anyway.

 Example of androidX reference: 'androidx/test/runner/lifecycle/Stage'

 Example of support library reference: 'android/support/annotation/NonNull'
Running Gradle task 'assembleRelease'...                          292.5s
✓  Built build/app/outputs/flutter-apk/app-release.apk (25.0MB).
2021-09-15 15:19:43,313 DEBUG: Popen(['git', 'cat-file', '--batch-check'], cwd=/home/vagrant/build/com.jonjomckay.fritter, universal_newlines=False, shell=None)
2021-09-15 15:19:43,320 INFO: Successfully built version 2.14.0 of com.jonjomckay.fritter from fc42370039eb509a68020f9f5ecdf7d2a5305997
2021-09-15 15:19:44,463 DEBUG: AXML contains a RESOURCE MAP
2021-09-15 15:19:44,464 DEBUG: Start of Namespace mapping: prefix 27: 'android' --> uri 62: 'http://schemas.android.com/apk/res/android'
2021-09-15 15:19:44,466 DEBUG: Checking build/com.jonjomckay.fritter/build/app/outputs/apk/release/app-release.apk
2021-09-15 15:19:44,468 DEBUG: AXML contains a RESOURCE MAP
2021-09-15 15:19:44,468 DEBUG: Start of Namespace mapping: prefix 27: 'android' --> uri 62: 'http://schemas.android.com/apk/res/android'
2021-09-15 15:19:44,499 INFO: success: com.jonjomckay.fritter
2021-09-15 15:19:44,500 INFO: Finished
2021-09-15 15:19:44,500 INFO: 1 build succeeded