log for com.quinncasey.paperless_share:1008

Traceback (most recent call last):
  File "/home/fbuild/fdroidserver/fdroidserver/build.py", line 1127, in main
    options.onserver, options.refresh):
  File "/home/fbuild/fdroidserver/fdroidserver/build.py", line 885, in trybuild
    build_server(app, build, vcs, build_dir, output_dir, log_dir, force)
  File "/home/fbuild/fdroidserver/fdroidserver/build.py", line 268, in build_server
    str(output, 'utf-8'))
fdroidserver.exception.BuildException: Build.py failed on server for com.quinncasey.paperless_share:1.1.1
==== detail begin ====
== Installed Android Tools ==

2022-01-15 03:48:29,218 DEBUG: Reading 'config.yml'
2022-01-15 03:48:29,228 INFO: Using /opt/android-sdk/build-tools/29.0.3/apksigner 
2022-01-15 03:48:29,231 INFO: Creating log directory
2022-01-15 03:48:29,231 INFO: Creating temporary directory
2022-01-15 03:48:29,232 INFO: Creating output directory
2022-01-15 03:48:29,234 DEBUG: Getting git vcs interface for https://github.com/qcasey/paperless_share
2022-01-15 03:48:29,235 DEBUG: > git --version
git version 2.11.0
2022-01-15 03:48:29,449 INFO: Using git version 2.11.0
2022-01-15 03:48:29,449 DEBUG: Checking 1.1.1
2022-01-15 03:48:29,450 INFO: Building version 1.1.1 (1008) of com.quinncasey.paperless_share
2022-01-15 03:48:29,451 DEBUG: > sudo passwd --lock root
passwd: password expiry information changed.
2022-01-15 03:48:29,659 DEBUG: > sudo SUDO_FORCE_REMOVE=yes dpkg --purge sudo
(Reading database ... 64893 files and directories currently installed.)
Removing sudo (1.8.19p1-2.1+deb9u3) ...
Purging configuration files for sudo (1.8.19p1-2.1+deb9u3) ...
Processing triggers for systemd (232-25+deb9u13) ...
2022-01-15 03:48:35,346 INFO: Getting source for revision d7918971117375ded70bb953e6a513717ce29473
2022-01-15 03:48:35,346 DEBUG: Directory: build/com.quinncasey.paperless_share
2022-01-15 03:48:35,346 DEBUG: > git rev-parse --show-toplevel
2022-01-15 03:48:35,550 DEBUG: Directory: build/com.quinncasey.paperless_share
2022-01-15 03:48:35,550 DEBUG: > git submodule foreach --recursive git reset --hard
2022-01-15 03:48:35,655 DEBUG: Directory: build/com.quinncasey.paperless_share
2022-01-15 03:48:35,655 DEBUG: > git reset --hard
2022-01-15 03:48:35,953 DEBUG: Directory: build/com.quinncasey.paperless_share
2022-01-15 03:48:35,953 DEBUG: > git submodule foreach --recursive git clean -dffx
2022-01-15 03:48:36,058 DEBUG: Directory: build/com.quinncasey.paperless_share
2022-01-15 03:48:36,059 DEBUG: > git clean -dffx
2022-01-15 03:48:36,308 DEBUG: Directory: build/com.quinncasey.paperless_share
2022-01-15 03:48:36,309 DEBUG: > git -c core.askpass=/bin/true -c core.sshCommand=/bin/false -c url.https://.insteadOf=ssh:// -c url.https://u:p@bitbucket.org/.insteadOf=git@bitbucket.org: -c url.https://u:p@bitbucket.org.insteadOf=git://bitbucket.org -c url.https://u:p@bitbucket.org.insteadOf=https://bitbucket.org -c url.https://u:p@github.com/.insteadOf=git@github.com: -c url.https://u:p@github.com.insteadOf=git://github.com -c url.https://u:p@github.com.insteadOf=https://github.com -c url.https://u:p@gitlab.com/.insteadOf=git@gitlab.com: -c url.https://u:p@gitlab.com.insteadOf=git://gitlab.com -c url.https://u:p@gitlab.com.insteadOf=https://gitlab.com fetch origin
2022-01-15 03:48:36,636 DEBUG: Directory: build/com.quinncasey.paperless_share
2022-01-15 03:48:36,637 DEBUG: > git -c core.askpass=/bin/true -c core.sshCommand=/bin/false -c url.https://.insteadOf=ssh:// -c url.https://u:p@bitbucket.org/.insteadOf=git@bitbucket.org: -c url.https://u:p@bitbucket.org.insteadOf=git://bitbucket.org -c url.https://u:p@bitbucket.org.insteadOf=https://bitbucket.org -c url.https://u:p@github.com/.insteadOf=git@github.com: -c url.https://u:p@github.com.insteadOf=git://github.com -c url.https://u:p@github.com.insteadOf=https://github.com -c url.https://u:p@gitlab.com/.insteadOf=git@gitlab.com: -c url.https://u:p@gitlab.com.insteadOf=git://gitlab.com -c url.https://u:p@gitlab.com.insteadOf=https://gitlab.com remote prune origin
2022-01-15 03:48:36,956 DEBUG: Directory: build/com.quinncasey.paperless_share
2022-01-15 03:48:36,957 DEBUG: > git -c core.askpass=/bin/true -c core.sshCommand=/bin/false -c url.https://.insteadOf=ssh:// -c url.https://u:p@bitbucket.org/.insteadOf=git@bitbucket.org: -c url.https://u:p@bitbucket.org.insteadOf=git://bitbucket.org -c url.https://u:p@bitbucket.org.insteadOf=https://bitbucket.org -c url.https://u:p@github.com/.insteadOf=git@github.com: -c url.https://u:p@github.com.insteadOf=git://github.com -c url.https://u:p@github.com.insteadOf=https://github.com -c url.https://u:p@gitlab.com/.insteadOf=git@gitlab.com: -c url.https://u:p@gitlab.com.insteadOf=git://gitlab.com -c url.https://u:p@gitlab.com.insteadOf=https://gitlab.com fetch --prune --tags --force origin
2022-01-15 03:48:37,271 DEBUG: Directory: build/com.quinncasey.paperless_share
2022-01-15 03:48:37,271 DEBUG: > git remote set-head origin --auto
2022-01-15 03:48:37,687 DEBUG: Directory: build/com.quinncasey.paperless_share
2022-01-15 03:48:37,687 DEBUG: > git checkout -f d7918971117375ded70bb953e6a513717ce29473
2022-01-15 03:48:37,897 DEBUG: Directory: build/com.quinncasey.paperless_share
2022-01-15 03:48:37,898 DEBUG: > git clean -dffx
2022-01-15 03:48:38,007 INFO: Collecting source libraries
2022-01-15 03:48:38,088 DEBUG: Removing debuggable flags from build/srclib/flutter
2022-01-15 03:48:38,141 INFO: Creating local.properties file at build/com.quinncasey.paperless_share/local.properties
2022-01-15 03:48:38,142 DEBUG: Removing debuggable flags from build/com.quinncasey.paperless_share
2022-01-15 03:48:38,146 INFO: Cleaned build.gradle of keysigning configs at build/com.quinncasey.paperless_share/android/app/build.gradle
2022-01-15 03:48:38,152 INFO: Scanning source for common problems...
2022-01-15 03:48:38,161 INFO: Creating source tarball...
2022-01-15 03:48:38,303 INFO: Running 'build' commands in build/com.quinncasey.paperless_share
2022-01-15 03:48:38,304 DEBUG: Directory: build/com.quinncasey.paperless_share
2022-01-15 03:48:38,304 DEBUG: > bash -x -c export PATH=/home/vagrant/build/srclib/flutter/bin:$PATH && /home/vagrant/build/srclib/flutter/bin/flutter config --no-analytics && /home/vagrant/build/srclib/flutter/bin/flutter packages pub get && /home/vagrant/build/srclib/flutter/bin/flutter packages pub run flutter_launcher_icons:main && /home/vagrant/build/srclib/flutter/bin/flutter build apk
+ export PATH=/home/vagrant/build/srclib/flutter/bin::/usr/local/bin:/usr/bin:/bin:/usr/local/games:/usr/games:/opt/android-sdk/tools:/opt/android-sdk/platform-tools:/opt/gradle/bin
+ PATH=/home/vagrant/build/srclib/flutter/bin::/usr/local/bin:/usr/bin:/bin:/usr/local/games:/usr/games:/opt/android-sdk/tools:/opt/android-sdk/platform-tools:/opt/gradle/bin
+ /home/vagrant/build/srclib/flutter/bin/flutter config --no-analytics
Downloading Dart SDK from Flutter engine b09f014e9658da6647361e7e416d1a159d34192d...
  % Total    % Received % Xferd  Average Speed   Time    Time     Time  Current
                                 Dload  Upload   Total   Spent    Left  Speed

  0     0    0     0    0     0      0      0 --:--:-- --:--:-- --:--:--     0
  0  194M    0 15159    0     0  28897      0  1:57:30 --:--:--  1:57:30 28874
 40  194M   40 77.9M    0     0  52.1M      0  0:00:03  0:00:01  0:00:02 52.1M
 83  194M   83  163M    0     0  65.4M      0  0:00:02  0:00:02 --:--:-- 65.3M
100  194M  100  194M    0     0  70.3M      0  0:00:02  0:00:02 --:--:-- 70.3M
Building flutter tool...

  ╔════════════════════════════════════════════════════════════════════════════╗
  ║                 Welcome to Flutter! - https://flutter.dev                  ║
  ║                                                                            ║
  ║ The Flutter tool uses Google Analytics to anonymously report feature usage ║
  ║ statistics and basic crash reports. This data is used to help improve      ║
  ║ Flutter tools over time.                                                   ║
  ║                                                                            ║
  ║ Flutter tool analytics are not sent on the very first run. To disable      ║
  ║ reporting, type 'flutter config --no-analytics'. To display the current    ║
  ║ setting, type 'flutter config'. If you opt out of analytics, an opt-out    ║
  ║ event will be sent, and then no further information will be sent by the    ║
  ║ Flutter tool.                                                              ║
  ║                                                                            ║
  ║ By downloading the Flutter SDK, you agree to the Google Terms of Service.  ║
  ║ Note: The Google Privacy Policy describes how data is handled in this      ║
  ║ service.                                                                   ║
  ║                                                                            ║
  ║ Moreover, Flutter includes the Dart SDK, which may send usage metrics and  ║
  ║ crash reports to Google.                                                   ║
  ║                                                                            ║
  ║ Read about data we send with crash reports:                                ║
  ║ https://flutter.dev/docs/reference/crash-reporting                         ║
  ║                                                                            ║
  ║ See Google's privacy policy:                                               ║
  ║ https://policies.google.com/privacy                                        ║
  ╚════════════════════════════════════════════════════════════════════════════╝

Analytics reporting disabled.

You may need to restart any open editors for them to read new settings.
+ /home/vagrant/build/srclib/flutter/bin/flutter packages pub get
Downloading Material fonts...                                      564ms
Downloading Gradle Wrapper...                                      142ms
Downloading package sky_engine...                                  263ms
Downloading flutter_patched_sdk tools...                         1,525ms
Downloading flutter_patched_sdk_product tools...                 1,364ms
Downloading linux-x64 tools...                                   2,235ms
Downloading linux-x64/font-subset tools...                         732ms
Resolving dependencies...
The current Dart SDK version is 2.12.3.

Because no versions of encrypted_shared_preferences match >3.0.0 <4.0.0 and encrypted_shared_preferences 3.0.0 depends on shared_preferences ^2.0.8, encrypted_shared_preferences ^3.0.0 requires shared_preferences ^2.0.8.
So, because shared_preferences >=2.0.8 requires SDK version >=2.14.0 <3.0.0 and paperless_share depends on encrypted_shared_preferences ^3.0.0, version solving failed.
pub finished with exit code 1
2022-01-15 03:49:26,300 ERROR: Could not build app com.quinncasey.paperless_share: Error running build command for com.quinncasey.paperless_share:1.1.1
==== detail begin ====
+ export PATH=/home/vagrant/build/srclib/flutter/bin::/usr/local/bin:/usr/bin:/bin:/usr/local/games:/usr/games:/opt/android-sdk/tools:/opt/android-sdk/platform-tools:/opt/gradle/bin
+ PATH=/home/vagrant/build/srclib/flutter/bin::/usr/local/bin:/usr/bin:/bin:/usr/local/games:/usr/games:/opt/android-sdk/tools:/opt/android-sdk/platform-tools:/opt/gradle/bin
+ /home/vagrant/build/srclib/flutter/bin/flutter config --no-analytics
Downloading Dart SDK from Flutter engine b09f014e9658da6647361e7e416d1a159d34192d...
  % Total    % Received % Xferd  Average Speed   Time    Time     Time  Current
                                 Dload  Upload   Total   Spent    Left  Speed

  0     0    0     0    0     0      0      0 --:--:-- --:--:-- --:--:--     0
  0  194M    0 15159    0     0  28897      0  1:57:30 --:--:--  1:57:30 28874
 40  194M   40 77.9M    0     0  52.1M      0  0:00:03  0:00:01  0:00:02 52.1M
 83  194M   83  163M    0     0  65.4M      0  0:00:02  0:00:02 --:--:-- 65.3M
100  194M  100  194M    0     0  70.3M      0  0:00:02  0:00:02 --:--:-- 70.3M
Building flutter tool...

  ╔════════════════════════════════════════════════════════════════════════════╗
  ║                 Welcome to Flutter! - https://flutter.dev                  ║
  ║                                                                            ║
  ║ The Flutter tool uses Google Analytics to anonymously report feature usage ║
  ║ statistics and basic crash reports. This data is used to help improve      ║
  ║ Flutter tools over time.                                                   ║
  ║                                                                            ║
  ║ Flutter tool analytics are not sent on the very first run. To disable      ║
  ║ reporting, type 'flutter config --no-analytics'. To display the current    ║
  ║ setting, type 'flutter config'. If you opt out of analytics, an opt-out    ║
  ║ event will be sent, and then no further information will be sent by the    ║
  ║ Flutter tool.                                                              ║
  ║                                                                            ║
  ║ By downloading the Flutter SDK, you agree to the Google Terms of Service.  ║
  ║ Note: The Google Privacy Policy describes how data is handled in this      ║
  ║ service.                                                                   ║
  ║                                                                            ║
  ║ Moreover, Flutter includes the Dart SDK, which may send usage metrics and  ║
  ║ crash reports to Google.                                                   ║
  ║                                                                            ║
  ║ Read about data we send with crash reports:                                ║
  ║ https://flutter.dev/docs/reference/crash-reporting                         ║
  ║                                                                            ║
  ║ See Google's privacy policy:                                               ║
  ║ https://policies.google.com/privacy                                        ║
  ╚════════════════════════════════════════════════════════════════════════════╝

Analytics reporting disabled.

You may need to restart any open editors for them to read new settings.
+ /home/vagrant/build/srclib/flutter/bin/flutter packages pub get
Downloading Material fonts...                                      564ms
Downloading Gradle Wrapper...                                      142ms
Downloading package sky_engine...                                  263ms
Downloading flutter_patched_sdk tools...                         1,525ms
Downloading flutter_patched_sdk_product tools...                 1,364ms
Downloading linux-x64 tools...                                   2,235ms
Downloading linux-x64/font-subset tools...                         732ms
Resolving dependencies...
The current Dart SDK version is 2.12.3.

Because no versions of encrypted_shared_preferences match >3.0.0 <4.0.0 and encrypted_shared_preferences 3.0.0 depends on shared_preferences ^2.0.8, encrypted_shared_preferences ^3.0.0 requires shared_preferences ^2.0.8.
So, because shared_preferences >=2.0.8 requires SDK version >=2.14.0 <3.0.0 and paperless_share depends on encrypted_shared_preferences ^3.0.0, version solving failed.
pub finished with exit code 1
==== detail end ====
2022-01-15 03:49:26,303 DEBUG: Error encoutered, stopping by user request.
==== detail end ====