log for com.waist.line:30109

Traceback (most recent call last):
  File "/home/fbuild/fdroidserver/fdroidserver/build.py", line 1136, in main
    options.onserver, options.refresh):
  File "/home/fbuild/fdroidserver/fdroidserver/build.py", line 886, in trybuild
    build_server(app, build, vcs, build_dir, output_dir, log_dir, force)
  File "/home/fbuild/fdroidserver/fdroidserver/build.py", line 269, in build_server
    str(output, 'utf-8'))
fdroidserver.exception.BuildException: Build.py failed on server for com.waist.line:3.1.9
==== detail begin ====
== Installed Android Tools ==

2021-10-11 22:14:43,940 DEBUG: Reading 'config.yml'
2021-10-11 22:14:43,952 INFO: Using /opt/android-sdk/build-tools/29.0.3/apksigner 
2021-10-11 22:14:43,955 INFO: Creating log directory
2021-10-11 22:14:43,955 INFO: Creating temporary directory
2021-10-11 22:14:43,955 INFO: Creating output directory
2021-10-11 22:14:43,974 DEBUG: Getting git vcs interface for https://github.com/davidhealey/waistline.git
2021-10-11 22:14:43,974 DEBUG: > git --version
git version 2.11.0
2021-10-11 22:14:44,186 INFO: Using git version 2.11.0
2021-10-11 22:14:44,186 DEBUG: Checking 3.1.9
2021-10-11 22:14:44,186 INFO: Building version 3.1.9 (30109) of com.waist.line
2021-10-11 22:14:44,187 INFO: Running 'sudo' commands in /home/vagrant
2021-10-11 22:14:44,187 DEBUG: > sudo DEBIAN_FRONTEND=noninteractive bash -x -c sysctl fs.inotify.max_user_watches=524288 && curl -Lo node.tar.xz https://nodejs.org/dist/v14.17.4/node-v14.17.4-linux-x64.tar.xz && echo "db18c54ebe01974d46198b08729249acbb0dcdc9aea82b53eec913f8c56035c6 node.tar.xz" | sha256sum -c - && tar xJf node.tar.xz --strip-components=1 -C /usr/local/ && npm install -g cordova
+ sysctl fs.inotify.max_user_watches=524288
fs.inotify.max_user_watches = 524288
+ curl -Lo node.tar.xz https://nodejs.org/dist/v14.17.4/node-v14.17.4-linux-x64.tar.xz
  % Total    % Received % Xferd  Average Speed   Time    Time     Time  Current
                                 Dload  Upload   Total   Spent    Left  Speed

  0     0    0     0    0     0      0      0 --:--:-- --:--:-- --:--:--     0
100 20.7M  100 20.7M    0     0  73.4M      0 --:--:-- --:--:-- --:--:-- 73.5M
+ echo 'db18c54ebe01974d46198b08729249acbb0dcdc9aea82b53eec913f8c56035c6 node.tar.xz'
+ sha256sum -c -
node.tar.xz: OK
+ tar xJf node.tar.xz --strip-components=1 -C /usr/local/
+ npm install -g cordova
npm WARN deprecated request@2.88.2: request has been deprecated, see https://github.com/request/request/issues/3142
npm WARN deprecated har-validator@5.1.5: this library is no longer supported
npm WARN deprecated uuid@3.4.0: Please upgrade  to version 7 or higher.  Older versions may use Math.random() in certain circumstances, which is known to be problematic.  See https://v8.dev/blog/math-random for details.
/usr/local/bin/cordova -> /usr/local/lib/node_modules/cordova/bin/cordova
+ cordova@10.0.0
added 491 packages from 258 contributors in 24.899s
2021-10-11 22:15:13,958 DEBUG: > sudo passwd --lock root
passwd: password expiry information changed.
2021-10-11 22:15:14,173 DEBUG: > sudo SUDO_FORCE_REMOVE=yes dpkg --purge sudo
(Reading database ... 64914 files and directories currently installed.)
Removing sudo (1.8.19p1-2.1+deb9u3) ...
Purging configuration files for sudo (1.8.19p1-2.1+deb9u3) ...
Processing triggers for systemd (232-25+deb9u13) ...
2021-10-11 22:15:19,633 INFO: Getting source for revision f24c811b4ca4025f1d3494916fed047c0649c0e4
2021-10-11 22:15:19,634 DEBUG: Directory: build/com.waist.line
2021-10-11 22:15:19,634 DEBUG: > git rev-parse --show-toplevel
2021-10-11 22:15:19,838 DEBUG: Directory: build/com.waist.line
2021-10-11 22:15:19,838 DEBUG: > git submodule foreach --recursive git reset --hard
2021-10-11 22:15:19,949 DEBUG: Directory: build/com.waist.line
2021-10-11 22:15:19,949 DEBUG: > git reset --hard
2021-10-11 22:15:20,283 DEBUG: Directory: build/com.waist.line
2021-10-11 22:15:20,283 DEBUG: > git submodule foreach --recursive git clean -dffx
2021-10-11 22:15:20,389 DEBUG: Directory: build/com.waist.line
2021-10-11 22:15:20,390 DEBUG: > git clean -dffx
2021-10-11 22:15:20,494 DEBUG: Directory: build/com.waist.line
2021-10-11 22:15:20,495 DEBUG: > git -c core.askpass=/bin/true -c core.sshCommand=/bin/false -c url.https://.insteadOf=ssh:// -c url.https://u:p@bitbucket.org/.insteadOf=git@bitbucket.org: -c url.https://u:p@bitbucket.org.insteadOf=git://bitbucket.org -c url.https://u:p@bitbucket.org.insteadOf=https://bitbucket.org -c url.https://u:p@github.com/.insteadOf=git@github.com: -c url.https://u:p@github.com.insteadOf=git://github.com -c url.https://u:p@github.com.insteadOf=https://github.com -c url.https://u:p@gitlab.com/.insteadOf=git@gitlab.com: -c url.https://u:p@gitlab.com.insteadOf=git://gitlab.com -c url.https://u:p@gitlab.com.insteadOf=https://gitlab.com fetch origin
2021-10-11 22:15:20,901 DEBUG: Directory: build/com.waist.line
2021-10-11 22:15:20,901 DEBUG: > git -c core.askpass=/bin/true -c core.sshCommand=/bin/false -c url.https://.insteadOf=ssh:// -c url.https://u:p@bitbucket.org/.insteadOf=git@bitbucket.org: -c url.https://u:p@bitbucket.org.insteadOf=git://bitbucket.org -c url.https://u:p@bitbucket.org.insteadOf=https://bitbucket.org -c url.https://u:p@github.com/.insteadOf=git@github.com: -c url.https://u:p@github.com.insteadOf=git://github.com -c url.https://u:p@github.com.insteadOf=https://github.com -c url.https://u:p@gitlab.com/.insteadOf=git@gitlab.com: -c url.https://u:p@gitlab.com.insteadOf=git://gitlab.com -c url.https://u:p@gitlab.com.insteadOf=https://gitlab.com fetch --prune --tags --force origin
2021-10-11 22:15:21,220 DEBUG: Directory: build/com.waist.line
2021-10-11 22:15:21,221 DEBUG: > git remote set-head origin --auto
2021-10-11 22:15:21,631 DEBUG: Directory: build/com.waist.line
2021-10-11 22:15:21,631 DEBUG: > git checkout -f f24c811b4ca4025f1d3494916fed047c0649c0e4
2021-10-11 22:15:21,939 DEBUG: Directory: build/com.waist.line
2021-10-11 22:15:21,939 DEBUG: > git clean -dffx
2021-10-11 22:15:22,044 INFO: Collecting source libraries
2021-10-11 22:15:22,049 DEBUG: Removing debuggable flags from build/srclib/BarcodeScanner
2021-10-11 22:15:22,053 INFO: Creating local.properties file at build/com.waist.line/local.properties
2021-10-11 22:15:22,053 DEBUG: Removing debuggable flags from build/com.waist.line
2021-10-11 22:15:22,083 INFO: Running 'prebuild' commands in build/com.waist.line
2021-10-11 22:15:22,083 DEBUG: Directory: build/com.waist.line
2021-10-11 22:15:22,083 DEBUG: > bash -x -c -- /opt/android-sdk/tools/bin/sdkmanager 'platforms;android-30' 'build-tools;30.0.3' > /dev/null
+ /opt/android-sdk/tools/bin/sdkmanager 'platforms;android-30' 'build-tools;30.0.3'
Warning: File /home/vagrant/.android/repositories.cfg could not be loaded.
2021-10-11 22:15:33,723 INFO: Scanning source for common problems...
2021-10-11 22:15:33,792 INFO: Creating source tarball...
2021-10-11 22:15:36,224 INFO: Running 'build' commands in build/com.waist.line
2021-10-11 22:15:36,224 DEBUG: Directory: build/com.waist.line
2021-10-11 22:15:36,225 DEBUG: > bash -x -c npm install && cordova platform add android && pushd /home/vagrant/build/srclib/BarcodeScanner && rm local.properties && gradle clean assembleRelease && popd && cp /home/vagrant/build/srclib/BarcodeScanner/barcodescanner/build/outputs/aar/barcodescanner-release.aar platforms/android/app/libs/barcodescanner-release-2.1.5.aar && cordova build android --release -- --packageType=apk
+ npm install
npm WARN read-shrinkwrap This version of npm is compatible with lockfileVersion@1, but package-lock.json was generated for lockfileVersion@2. I'll try to do my best with it!
npm ERR! code EBADPLATFORM
npm ERR! notsup Unsupported platform for fsevents@2.3.2: wanted {"os":"darwin","arch":"any"} (current: {"os":"linux","arch":"x64"})
npm ERR! notsup Valid OS:    darwin
npm ERR! notsup Valid Arch:  any
npm ERR! notsup Actual OS:   linux
npm ERR! notsup Actual Arch: x64

npm ERR! A complete log of this run can be found in:
npm ERR!     /home/vagrant/.npm/_logs/2021-10-11T22_15_37_496Z-debug.log
2021-10-11 22:15:37,647 ERROR: Could not build app com.waist.line: Error running build command for com.waist.line:3.1.9
==== detail begin ====
+ npm install
npm WARN read-shrinkwrap This version of npm is compatible with lockfileVersion@1, but package-lock.json was generated for lockfileVersion@2. I'll try to do my best with it!
npm ERR! code EBADPLATFORM
npm ERR! notsup Unsupported platform for fsevents@2.3.2: wanted {"os":"darwin","arch":"any"} (current: {"os":"linux","arch":"x64"})
npm ERR! notsup Valid OS:    darwin
npm ERR! notsup Valid Arch:  any
npm ERR! notsup Actual OS:   linux
npm ERR! notsup Actual Arch: x64

npm ERR! A complete log of this run can be found in:
npm ERR!     /home/vagrant/.npm/_logs/2021-10-11T22_15_37_496Z-debug.log
==== detail end ====
2021-10-11 22:15:37,647 DEBUG: Error encoutered, stopping by user request.
==== detail end ====